[Bug 655719] wayland video sink: initial implementation

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Wed Aug 10 05:35:49 PDT 2011


https://bugzilla.gnome.org/show_bug.cgi?id=655719
  GStreamer | gst-plugins-bad | git

--- Comment #6 from sreerenj <bsreerenj at gmail.com> 2011-08-10 12:35:47 UTC ---
(In reply to comment #5)
> I would have some naming nitpicks:
> 
> typedef struct _GstWayLandSink GstWayLandSink;
> 
> only use camer case for separate words. that is just call it GstWaylandSink
> ("wayland" is one name and not "way land" to my knowledge).
> 

Yup,You are right.I already got the same comment from Wayland developers:)
Thanks for the reminder.

> 
> in the header you have
> typedef struct wl_display WlDisplay;
> typedef struct wl_buffer WlBuffer;
> and then
> struct  display { ... }
> struct  window { ... }
> 

I will change the structuring later.

> some copy'n'paste bugs? is the wl_buffer thing meant to be the window and is
> the "wl_" prefix missing on the structs?
> 

struct wl_surface *surface;
struct wl_buffer *buffer;

are the needed structures. wl_buffer is the wayland-shm buffer.(To supply them
to the compositor)

> in the c-file I saw a  g_usleep (50000), that I hope you will replace. Always
> good to add FIXME comments for the things you know that are WIP.

Yup.I put the g_usleep to make sure that there is no dead lock even compositor
didn't replied. Which needs to be remove.

It is still a prototype to show the video playback in wayland. :)

Thanks for the comments.

-- 
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list