[Bug 658495] Create config of expected failures for samplemedia.linaro.org files

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Thu Sep 15 09:28:04 PDT 2011

  GStreamer | gst-qa-system | unspecified

--- Comment #3 from David Laban <alsuren at gmail.com> 2011-09-15 16:27:59 UTC ---
(In reply to comment #2)
> ++ as of 21890029ccf8e1e51cea494151d1c77c652a2c07
> Rework of the settings dict makes sense.
> A couple of minor nitpicks:
> * hardcoding of the sample media root is unfortunate; can it
>   be derived somehow from the location of the Django app? or
>   at least define SAMPLEMEDIA_ROOT like in comment #1

> * use if '0' and 'None' in settings is kind of ugly,
>   would be nicer if 0 and None could be used (cast them
>   to str() in check?)
It's not in check that the problem lies: it's:

2011-09-15 17:46:23,752  0x7fde7f082700       ERROR 
connection.py:571:call_async: Unable to set arguments
('/home/alsuren/src/gst-qa-system/tests/ismedia.pyc', 'tests.ismedia',
'IsMediaTest', {'uuid': '4496cdbbe14d189d04135489f2914d65', 'uri':
'expected-failures': [


], 'bus_address':
'proxy': True, 'timeout': 15}) according to signature u'sssa{sv}': <type
'exceptions.TypeError'>: Expected a string or unicode object
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/dbus/connection.py", line 586, in
  File "/usr/lib/python2.6/dist-packages/dbus/proxies.py", line 397, in
  File "/usr/lib/python2.6/dist-packages/dbus/proxies.py", line 383, in
    proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/dist-packages/dbus/proxies.py", line 135, in
  File "/usr/lib/python2.6/dist-packages/dbus/connection.py", line 566, in
    message.append(signature=signature, *args)
TypeError: Expected a string or unicode object

I think that dbus-python expects homogeneous types (I assume that this is why
you gave up on your previously planned idea of passing filter functions in?). I
know that it's horrible. If you can think of a better solution, I'm all ears.

To aid debugging, I added an assert in settings.py.

> in insanity/scenario.py:
> * in docstring "would nit be" -> "would not be"
> * although you did leave a comment there, having
>   sub.getFullArgumentList() vs sub._getFullArgumentList()
>   is somewhat confusing, maybe rename it to something
>   reflecting the difference? or just make it a small helper
>   function inside getArguments, if it's the only one
>   that's going to use it?
> in insanity/test.py:
>   if checkitem not in results:
>      continue
>   elif ..:
>      ...
> since the first if is a guard and the rest is only executed if it passes, I
> think this is more readable:
>   if checkitem not in results:
>     continue
>   if ..

Fixed and appended to the branch (I also snuck in one commit from lava-658912
because I knew it would conflict later). If you want me to rebase/squash
anything, I can.

Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the gstreamer-bugs mailing list