[Bug 752441] gtk: Create a base class to remove code duplication

GStreamer (GNOME Bugzilla) bugzilla at gnome.org
Fri Jul 17 06:55:26 PDT 2015


https://bugzilla.gnome.org/show_bug.cgi?id=752441

Xavier Claessens <xclaesse at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #307587|none                        |reviewed
             status|                            |

--- Comment #9 from Xavier Claessens <xclaesse at gmail.com> ---
Review of attachment 307587:
 --> (https://bugzilla.gnome.org/review?bug=752441&attachment=307587)

::: ext/gtk/gtkgstbasewidget.c
@@ +280,3 @@
+
+  if (widget->reset)
+    widget->reset (widget);

You don't seems to ever set a value to widget->reset()

@@ +290,3 @@
+  if (!widget->resize_id) {
+    widget->resize_id = g_idle_add_full (G_PRIORITY_DEFAULT,
+        (GSourceFunc) _queue_resize, widget, NULL);

You don't need _full if you set DEFAULT priority and no destroynotify.

@@ +312,3 @@
+  if (!widget->draw_id) {
+    widget->draw_id = g_idle_add_full (G_PRIORITY_DEFAULT,
+        (GSourceFunc) _queue_draw, widget, NULL);

You don't need _full if you set DEFAULT priority and no destroynotify.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list