[Bug 752441] gtk: Create a base class to remove code duplication
GStreamer (GNOME Bugzilla)
bugzilla at gnome.org
Fri Jul 17 07:10:25 PDT 2015
https://bugzilla.gnome.org/show_bug.cgi?id=752441
Xavier Claessens <xclaesse at gmail.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #307590|none |reviewed
status| |
--- Comment #10 from Xavier Claessens <xclaesse at gmail.com> ---
Review of attachment 307590:
--> (https://bugzilla.gnome.org/review?bug=752441&attachment=307590)
::: ext/gtk/gstgtkbasesink.c
@@ +150,3 @@
+{
+ if (gtk_sink->widget != NULL)
+ return gtk_sink->widget;
I would add here an assert that we are in the main thread. Something like:
g_assert (g_main_context_is_owner(NULL));
But the default main context could not yet be acquired, if we are called from
main() before we first call g_main_loop_run(), I think.
Maybe rather:
g_assert (g_main_context_acquire(NULL));
But then you have to release it somewhere...
Maybe just add a comment saying it must happen in GTK thread. And at least tell
it in the property doc.
@@ +249,3 @@
+ window = gtk_window_new (GTK_WINDOW_TOPLEVEL);
+ gtk_window_set_default_size (GTK_WINDOW (window), 640, 480);
+ gtk_window_set_title (GTK_WINDOW (window), "Gtk+ Cairo renderer");
The title must come from subclass.
--
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
More information about the gstreamer-bugs
mailing list