[Bug 784908] v4l2videodec: Implement stable naming scheme for elements
GStreamer (GNOME Bugzilla)
bugzilla at gnome.org
Fri Jul 14 09:17:50 UTC 2017
https://bugzilla.gnome.org/show_bug.cgi?id=784908
--- Comment #14 from Michael Tretter <m.tretter at pengutronix.de> ---
Review of attachment 355538:
--> (https://bugzilla.gnome.org/review?bug=784908&attachment=355538)
::: sys/v4l2/gstv4l2videodec.c
@@ +1034,3 @@
+ } else {
+ gchar *s_str = gst_structure_to_string (s);
+ SET_META ("MPEG2");
I'm not sure if the warning is better than falling back to v4l2<node>dec. You
are handling a lot more codecs that I did and adding a new mapping is easy, so
this is probably unlikely. However, having a fallback that works with playbin
and doesn't require a change here sounds reasonable to me. Maybe we want both,
the warning and the fallback.
@@ +1042,3 @@
+ if (g_type_from_name (type_name) != 0) {
+ g_free (type_name);
+ } else if (gst_structure_has_name (s, "video/x-h263")) {
This leads to v4l2<node><codec>dec names, which conflicts with my expectation
and your commit message.
--
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
More information about the gstreamer-bugs
mailing list