[Bug 784908] v4l2videodec: Implement stable naming scheme for elements
GStreamer (GNOME Bugzilla)
bugzilla at gnome.org
Fri Jul 14 13:11:30 UTC 2017
https://bugzilla.gnome.org/show_bug.cgi?id=784908
--- Comment #15 from Nicolas Dufresne (stormer) <nicolas at ndufresne.ca> ---
(In reply to Michael Tretter from comment #14)
> Review of attachment 355538 [details] [review]:
>
> ::: sys/v4l2/gstv4l2videodec.c
> @@ +1034,3 @@
> + } else {
> + gchar *s_str = gst_structure_to_string (s);
> + SET_META ("MPEG2");
>
> I'm not sure if the warning is better than falling back to v4l2<node>dec.
> You are handling a lot more codecs that I did and adding a new mapping is
> easy, so this is probably unlikely. However, having a fallback that works
> with playbin and doesn't require a change here sounds reasonable to me.
> Maybe we want both, the warning and the fallback.
I thought about that, but if there is two unsupported formats, we'll have a
type_name clash. I have made sure to cover all formats marked has codecs in the
GstV4l2Object, so hitting this warning would be a programming error. I'll
improve the warning message.
>
> @@ +1042,3 @@
> + if (g_type_from_name (type_name) != 0) {
> + g_free (type_name);
> + } else if (gst_structure_has_name (s, "video/x-h263")) {
>
> This leads to v4l2<node><codec>dec names, which conflicts with my
> expectation and your commit message.
I'll double check, I flip it over during implementation to match the encoder
fallback.
Thanks for the review.
--
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
More information about the gstreamer-bugs
mailing list