[gst-devel] Greetings

Scott McCaskill scott at magruder.org
Mon Feb 7 07:10:24 CET 2000


I just noticed the gstreamer project last week while looking around
sourceforge, and it sounds a lot like something I had been working on by
myself off and on for some time.  Admittedly, my goals weren't as
lofty--basically I just wanted to be able to automatically record
streaming audio to a compressed format in real time at predefined times,
like a VCR--but the architecture I had come up with sounds a lot like the
architecture for gstreamer.  Since I'll probably get more done working
with others than working by myself, I figured I'd see what I can do on
this project.

Some brief background about myself:  I currently work for a game company,
and have for several years (prior to that I worked for a company that made
things like flight simulators).  Most of my experience is with real time
3d graphics, but I have done some work with audio here and there as well.
I've used and written code for IRIX, linux, and windows, and several game
console platforms, roughly in that order.  Here at home I have win98, NT,
and linux (RH 6.0).

I _think_ I have downloaded and installed everything I should need, but
I'm having a few problems building gstreamer.  Since there is no
'configure' script checked into the tree, I tried running autogen.sh (a
total guess on my part).  First it told me I needed libtool 1.2 or newer,
so I got 1.3.  I then ran autogen.sh again and it bombed out around here:
autoconf: Undefined macros:
Recursively running autogen.sh in plugins/mp3decode/xing/libxing/
You should add the contents of `/usr/local/share/aclocal/libtool.m4' to
aclocal: configure.in: 33: macro `AM_PROG_LIBTOOL' not found in library
loading cache ./config.cache
./configure: syntax error near unexpected token
./configure: ./configure: line 537: `AM_CONFIG_HEADER(config.h)'

Any ideas?  I looked at the file it said I needed to modify, but its
contents are already a superset of the file it says I need to add from
(well, assuming I was looking at the right file.. it didn't say where
aclocal.m4 was, so I assumed somewhere under /usr/local/share).  

I have never done more with the autoconf stuff than './configure ; make ;
make install' so if there's anything obvious I'm doing wrong I'd be
grateful for any pointers.


More information about the gstreamer-devel mailing list