[gst-devel] Daily IRC logs

wim.taymans at chello.be wim.taymans at chello.be
Sat May 5 06:27:39 CEST 2001

[07:07] Nick change: ajmitch -> aj_food
[07:28] Nick change: taaz -> taazzzz
[07:51] steveb (steveb at node1ee06.a2000.nl) joined #gstreamer.
[07:51] steveb (steveb at node1ee06.a2000.nl) left irc: [x]chat
[08:14] Nick change: aj_food -> ajmitch
[08:53] Nick change: ajmitch -> ajbusy
[09:00] omega_ (omega at omegacs.net) joined #gstreamer.
[09:00] omega_ (omega at omegacs.net) left irc: [x]chat
[09:00] omega_ (omega at omegacs.net) joined #gstreamer.
[09:00] <omega_> anyone awake?
[10:05] thomas (thomas at adsl-63633.turboline.skynet.be) joined #gstreamer.
[10:05] <omega_> yo
[10:05] <thomas> morning
[10:05] <thomas> how late is it where you are ?
[10:05] <thomas> ;)
[10:05] <omega_> 1:14am
[10:05] Action: omega_ is working on getting the LADSPA wrapper to work
[10:06] Action: thomas is going to the store to get his gbox
[10:06] <omega_> hehehe
[10:06] <omega_> I'm scheduled to give a talk on gstreamer at next month's PLUG meeting
[10:07] <thomas> they didn't get the g400 in time, seems like it's hard to find
[10:07] <thomas> omega_: great
[10:07] <omega_> yeah, they're not in production any more
[10:07] <thomas> where's P.  Poland ?
[10:07] <omega_> I'd like to report your success next month <g>
[10:07] <omega_> Portland
[10:07] <thomas> omega_: I'd like that too ;)
[10:07] <omega_> if it was Poland, I'd be in your timezone....
[10:07] <thomas> omega_: I don't know where they fly you all the time anyway...
[10:07] <omega_> hehehe
[10:08] Action: omega_ listens to kfmf mods via gstreamer with the xmms mikmod plugin <g>
[10:08] <thomas> btw I saw a pretty cool music box system on the web...
[10:08] <omega_> oh?
[10:08] <thomas> www.imerge.co.uk
[10:08] <thomas> do you know it ?
[10:08] <omega_> checking
[10:08] <thomas> looks like it runs embedded linux
[10:10] <omega_> any idea on cost?
[10:10] <thomas> no... I'd like to know though
[10:10] <thomas> we're working on something similar, so ...
[10:10] <thomas> you too at ridgerun ?
[10:11] <omega_> yeah, though in the long run I just want a box that goes from 100bt to the amp, no intellegence, leave that for the server
[10:11] <omega_> ridgerun does tools, not products
[10:11] <thomas> that sounds pretty general... you consider gstreamer more of a tool then ?
[10:11] <omega_> quite
[10:12] <omega_> the apps on top of it are the interesting bit, but gstreamer does nothing by itself
[10:12] <thomas> ok... but if ridgerun "sponsors" gstreamer ...
[10:12] <thomas> ... do they expect money from the support then ?
[10:13] <thomas> I've already had long discussions with my "boss" about open source in the commercial world...
[10:13] <thomas> ... it's hard to think in that frame of thought
[10:13] <omega_> gstreamer is one of many pieces they need to be able to sell companies on the idea of embedded linux
[10:14] <omega_> when a cell-phone manufacturer wants to put streaming video into their 3G phone, RidgeRun wants them to think DSPLinux, in part because we have significant experience with GStreamer (by definition <g>)
[10:14] <omega_> and some [near] future work I'll be doing that's specific to the target platform is something *no one* has even tried before
[10:16] <thomas> nice ... I suppose you're not allowed to talk about it ?
[10:16] <omega_> well, I can say that the target is a chip from TI that has an ARM9 core and a DSP on the same die
[10:16] <omega_> and you can probably figure out what that means from a gstreamer point of view
[10:17] <thomas> I don't have too much hardware knowledge, so I don't know what ARM9 is...
[10:17] <thomas> ... but the DSP suggests libcodec ;)
[10:17] <omega_> a processor
[10:18] <thomas> yeah, but what kind...
[10:18] <thomas> I'll check
[10:18] <omega_> actually, there are already plenty of people smarter than me working on algos for DSPs, so I think the plan is to defer to them... <g>
[10:18] <omega_> arm9 is basically an embedded chip
[10:18] <omega_> the iPAQ has a StrongARM, which is Intel's variant of the arm9
[10:18] <omega_> the Netwinder has another StrongARM
[10:19] <thomas> hmmm... what memoryspace do you expect to squeeze gstreamer in then ?
[10:19] <omega_> I think the target is on the order of 8MB flash and 8MB RAM
[10:19] <omega_> think cell phone
[10:19] <omega_> we have a target of 100KB for all gstreamer libraries and dependencies, excepting an ORB
[10:20] <omega_> plugins *don't* count in that total, of course <g>
[10:20] <omega_> 50KB would be wonderful, but that's pushing it
[10:20] <thomas> sounds like you've got your work cut out
[10:20] <thomas> I get to do it on a full PC system looking like a stereo
[10:20] <omega_> not really.... the current lib compiles to about 150KB if you turn off all the debugging stuff
[10:20] <thomas> so I'll just put on redhat ...
[10:20] <omega_> heh, yup
[10:21] <thomas> what time frame do they expect you to deliver ?
[10:21] <omega_> not sure, but we're working on about a 1 month horizon right now, so...
[10:21] <omega_> I'd guess something usable within ~3mo, shippable in 6mo
[10:21] <omega_> but thats a "wild a** guess"
[10:24] Action: thomas is struggling with gdk and transparent text
[10:24] <thomas> I *really* want that windowmaker effect for the gbox
[10:28] Action: omega_ needs to go to sleep....
[10:28] <omega_> ttyl
[10:28] <thomas> yeah, see you
[10:28] omega_ (omega at omegacs.net) left irc: [x]chat
[10:33] thomas (thomas at adsl-63633.turboline.skynet.be) left irc: Client Exiting
[10:53] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) joined #gstreamer.
[11:11] Nick change: maYam_sleep -> maYam
[11:45] Nick change: ajbusy -> ajzzzz
[13:17] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) left irc: Ping timeout for arik[adsl-64-174-42-2.dsl.snfc21.pacbell.net]
[13:17] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) joined #gstreamer.
[13:42] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) left irc: Ping timeout for arik[adsl-64-174-42-2.dsl.snfc21.pacbell.net]
[13:42] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) joined #gstreamer.
[13:46] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) left irc: Ping timeout for arik[adsl-64-174-42-2.dsl.snfc21.pacbell.net]
[14:35] maenzaed (manuel at a108007.upc-a.chello.nl) joined #gstreamer.
[14:35] maenzaed (manuel at a108007.upc-a.chello.nl) left #gstreamer (lilo: KVIrc).
[14:46] maenzaed (manuel at a108007.upc-a.chello.nl) joined #gstreamer.
[14:47] maenzaed (manuel at a108007.upc-a.chello.nl) left #gstreamer (lilo: KVIrc).
[16:05] Nick change: taazzzz -> taaz
[17:28] Uraeus (cschalle at c224s9h5.upc.chello.no) joined #gstreamer.
[17:28] <Uraeus> hiho
[17:36] _gst_newt_ joined #gstreamer.
[17:58] steveb (steveb at node1ee06.a2000.nl) joined #gstreamer.
[18:08] CHW_away (paul at temple-baptist.com) left irc: 
[18:21] CHW_away (paul at temple-baptist.com) joined #gstreamer.
[18:21] Nick change: CHW_away -> ChiefHighwater
[18:23] steveb (steveb at node1ee06.a2000.nl) left irc: Ping timeout for steveb[node1ee06.a2000.nl]
[18:24] steveb (steveb at node1ee06.a2000.nl) joined #gstreamer.
[19:15] dobey (dobey at dreadnought.ximian.com) joined #gstreamer.
[19:15] <dobey> hrmm
[19:15] <dobey> mayam, my love!
[19:17] Zeenix (programmer at joined #gstreamer.
[19:24] Zeenix (programmer at left irc: Ping timeout for Zeenix[]
[19:36] <ChiefHighwater> do be do be do
[19:37] <dobey> hrmm
[19:38] <ChiefHighwater> ?
[19:39] <dobey> no mayam
[19:39] Nick change: wtay-sleeping -> wtay
[19:39] <wtay> yoo
[19:41] <ChiefHighwater> ello
[19:41] <dobey> hey wtay
[19:50] <ChiefHighwater> ok wim, that Paul Davis guy is ready for his GStreamer Epiphany...you kbnow, that moment in a programmers mind when they finally can see the big picture...the old way of programming is abandoned and a the programmer delves into the docs tryin to absorb, as fast as possible, the concepts behind GStreamer.  He is standing at the precipise, all he needs now is a good push 8-]
[19:52] <ChiefHighwater> this is always fun to watch 8-]
[19:52] <wtay> ChiefHighwater: hmm, I'm not a good advocate at all IMHO...
[19:53] <dobey> hrmm
[19:53] <wtay> omega_ will give him a good push, I'm sure :-)
[19:53] <ChiefHighwater> I think you're a fine advocate, but omega seems to have this one in hand
[19:54] <wtay> He always tends to say the oposite I would say <g>
[19:54] <ChiefHighwater> hehe
[19:54] <wtay> And he's right...
[19:54] <dobey> hrmm
[19:54] <dobey> of course, he looks like me
[19:55] <wtay> I tend to speak in a more negative approach while he's more positive :)
[19:55] <ChiefHighwater> and he umm, err, he umm ...there's gotta be something, umm....rats
[19:55] Action: ChiefHighwater is not like omega 8-[
[19:57] <ChiefHighwater> wtay:you're not negative...if user comes in here and says...IS THERE ANY SANE WAY FOR ME TO PLAY MY MPEG2 FILES?....you just smile and say...you bet...let me introduce you to the_way_things_ought_to_be (tm)  8-]
[19:58] <wtay> ChiefHighwater: I guess it depends on my mood then :)
[19:58] <ChiefHighwater> hehe
[19:58] Action: dobey uploads theme
[19:59] Action: wtay wrote his first perl program yesterday..
[20:00] <wtay> aaah, snooker on tv...
[20:00] Nick change: wtay -> wtay-snooker
[20:00] <wtay-snooker> back in 1 hour
[20:00] <dobey> haha
[20:11] steveb (steveb at node1ee06.a2000.nl) left irc: Ping timeout for steveb[node1ee06.a2000.nl]
[20:11] Uraeus (cschalle at c224s9h5.upc.chello.no) left irc: Ping timeout for Uraeus[c224s9h5.upc.chello.no]
[20:11] Uraeus (cschalle at c224s9h5.upc.chello.no) joined #gstreamer.
[20:11] steveb (steveb at node1ee06.a2000.nl) joined #gstreamer.
[20:13] _gst_newt_ joined #gstreamer.
[20:15] hadess (hadess at pc121-gui14.cable.ntl.com) joined #gstreamer.
[20:15] <dobey> dude!
[20:15] <hadess> heya
[20:35] Uraeus (cschalle at c224s9h5.upc.chello.no) left irc: syntax error - user imploded
[20:36] <dobey> hadess: i'm about to upload my theme to gtk.t.o ;-)
[20:38] <dobey> http://primates.ximian.com/~dobey/leet.png
[20:42] omega_ (omega at omegacs.net) joined #gstreamer.
[20:44] <ChiefHighwater> ello
[20:44] <omega_> yo
[20:45] <ChiefHighwater> we all decided that you get to give Paul Davis his push into the GStreamer Epiphany he's begging for 8-]
[20:46] <omega_> hrm, /me reads mail
[20:46] <ChiefHighwater> that's a good start, yes 8-p
[20:47] <ChiefHighwater> how was the plug?
[20:47] <omega_> boring, but did get myself a spot speaking at the next one
[20:48] <ChiefHighwater> how many folks show at one of those?
[20:48] <omega_> this one had 50 or more
[20:49] <ChiefHighwater> kewl
[20:52] <dobey> wee
[20:52] <dobey> my theme is on gtk.t.o now, i think
[20:53] <dobey> eh, nope :/
[20:59] <hadess> dobey: it needs to be added to the database
[20:59] Nick change: wtay-snooker -> wtay
[20:59] <wtay> elloh
[20:59] <hadess> dobey: does you theme work with gnumeric ?
[20:59] <dobey> hadess: yeah
[20:59] <hadess> heya wtay
[20:59] <dobey> hrmm
[20:59] <dobey> hadess: define "work" everything is readable :-0
[21:00] <hadess> dobey: it doesn't have the same problems as clean, right ?
[21:00] <dobey> what problems was that?
[21:00] <dobey> brb
[21:01] <wtay> omega_: 've been looking at the oss wrapper... it uses LD_PRELOAD to override write/read etc.. 
[21:01] <omega_> yup
[21:01] <wtay> omega_: not sure what to preload though..
[21:01] <omega_> er, sorta
[21:01] <omega_> you're reading the esddsp.c code?
[21:01] <wtay> can't preload a plugins...
[21:02] <wtay> audiooss.c
[21:02] <omega_> hmm
[21:02] <omega_> look at esddsp.c
[21:02] <omega_> it's more more appropriate
[21:02] <wtay> also PRELOAD?
[21:02] <omega_> sorta
[21:03] <omega_> the element will likely require a support program to exec() the final program regardless
[21:03] <omega_> fork() to support, support preloads and exec()s the real program
[21:06] <wtay> hmm ok...
[21:06] <wtay> -launch ossgst program=realplayer ! lame ! disksink
[21:06] <omega_> right
[21:07] <dobey> hrmm
[21:07] <omega_> the trick is we need to extend the word-split code in gstparse.c in order to handle \" and \  better
[21:07] <omega_> or \', or whatever
[21:09] <omega_> the program arg needs to be a full string
[21:09] <wtay> I guess the mixer support is not really needed
[21:10] _gst_newt_0 joined #gstreamer.
[21:10] <dobey> hrmm
[21:10] <omega_> the trick is we need to extend the word-split code in gstparse.c in order to handle \" and \  better
[21:10] <omega_> or \', or whatever
[21:10] <omega_> the program arg needs to be a full string
[21:10] <omega_> hadess: yeah, sorta <g>
[21:10] Action: omega_ would much rather have a Real plugin wrapper
[21:10] Nick change: _gst_newt_0 -> _gst_newt_
[21:11] <hadess> omega_: actually, there's the realplayer sdk, but i think it needs realplayer installed...
[21:11] <wtay> omega_: there is a real media SDK somewhere but the license sucks
[21:11] <omega_> I should know, I used it for 3mo
[21:11] <wtay> you cannot give out the source code for the plugin or something
[21:11] Action: omega_ still twitches whenever he remembers back to that
[21:11] <omega_> wtay: who says we'd use the SDK???
[21:12] <hadess> wtay: you can give the source, but no binaries iirc
[21:12] <omega_> the SDK has no relevance to us, just the API
[21:12] <wtay> omega_: ok, I meant the headers to actually talk to the codec..
[21:12] <omega_> we have to write a big set of APIs that exist *only* *inside* realplayer in order to shim in real plugins
[21:13] <omega_> wtay: we don't need to grab their headers, since they won't compile nicely anyway
[21:13] <omega_> we do have to write a COM layer ;-(
[21:13] <wtay> ouch
[21:13] <omega_> which is why I'm not all that eager to jump into it
[21:13] <wtay> a COM layer, no *real* API?
[21:13] <omega_> exactly
[21:14] <wtay> pff
[21:14] <wtay> esddsp.c =~ audiooss.c
[21:15] <omega_> ok, I haven't looked at audiooss.c
[21:15] <omega_> but I'm not sure I want to use that lib necessarily
[21:15] <wtay> no, just take the code
[21:15] <omega_> yup
[21:15] <wtay> or esddsp.c, same thing
[21:15] <wtay> I'll take the one with the least crap in it to start from
[21:15] <dobey> ok
[21:16] <dobey> now my theme is on gtk.t.o
[21:17] <hadess> dobey: url
[21:17] <dobey> hadess: gtk.themes.org
[21:17] <dobey> it would be the "new" theme :-)
[21:17] <hadess> dobey: to the theme, in the databade
[21:18] <dobey> i dunno
[21:18] <hadess> got it
[21:18] <wtay> omega_: ok esddep.c is the most sane one
[21:18] Action: omega_ laughs
[21:18] <wtay> s/dep/dsp
[21:19] <omega_> heheheh
[21:19] <wtay> ?
[21:19] <hadess> dobey: heh, 404 on your theme
[21:19] <omega_> xmms has trouble playing mods
[21:19] <hadess> xmms sucks at playing mods
[21:20] <hadess> dobey: http://gtk.themes.org/themes.phtml?themeid=989002037
[21:20] <hadess> dobey: click on "Quick"...
[21:20] <omega_> but I can use -launch with the xmms mikmod plugin to play them just fine <g>
[21:20] <dobey> hrmm
[21:20] <dobey> on the tarball?
[21:20] <hadess> dobey: yep
[21:20] <wtay> omega_: wow!
[21:20] <dobey> oh
[21:21] <hadess> omega_: lol
[21:21] <dobey> http://gtk.themes.org/php/download.phtml?object=gtk.theme.989002037&rev=1.2.x
[21:21] <dobey> does that work?
[21:21] <omega_> one for the weekly summary? <g>
[21:21] <hadess> dobey: just gives a webpage and a 404 after
[21:50] <wtay> omega_: hmmm, how shall I do the inter process communication? shm? or just pipes?
[21:51] <dobey> hadess: bleh
[21:51] <omega_> shm would be preferrable of course
[21:51] <hadess> dobey: thanks
[21:51] <wtay> omega_: never done that :)
[21:51] <omega_> hmm, neither have I <g>
[21:51] <hadess> dobey: i'll make a debian package =)
[21:51] <omega_> man -k shm <g>
[21:52] <dobey> heh
[21:52] <wtay> omega_: the spawend process will also communitate the oss format to the parent so it can create the caps
[21:52] <omega_> right, via a pipe
[21:52] <dobey> anyone else want my theme and can do /dcc?
[21:52] <omega_> wtay: also remember that there's two directions here, both playback and record
[21:52] <wtay> omega_: hmm, I'll start with playback first
[21:52] <omega_> right
[21:52] <omega_> <g>
[21:53] Uraeus (cschalle at c224s9h5.upc.chello.no) joined #gstreamer.
[21:53] <wtay> I'll use a pipe for now
[21:53] <omega_> Uraeus: isn't it about time to gather stuff for the next summary?
[21:53] Action: wtay always tries something he knows about first...
[21:53] <Uraeus> omega_: steve is doing this one
[21:53] <omega_> steve
[21:53] <omega_> ?
[21:54] Action: hadess is away: watching telly
[21:54] <Uraeus> omega_: steve george, we are doing every other summary, but if you have something really major I can mail him about it
[21:54] <omega_> ok, response to pbd sent
[21:54] <omega_> heh, ok
[21:55] <wtay> omega_: also I'll preload the ossgst plugin, let's hope LD_PRELOAD does lazy binding or else I'll have to create a helper .so
[21:55] <Uraeus> omega_: think you will be able to convince him? seeing his mails make it clear why he never replied to my mail
[21:55] Action: omega_ listens to mods via gstreamer and the xmms mikmod plugin, because xmms hangs when he tries to play mods
[21:55] <omega_> Uraeus: he's very set, but I think I can get him to see the light
[21:55] <omega_> wtay: can you preload before a fork, without a helper app to exec()  ?
[21:56] <wtay> execv is a fork+env etc..
[21:56] <omega_> ah, ok
[21:56] <wtay> I think..
[21:56] <omega_> hrm, I think you have to fork first
[21:56] <omega_> but duh, you can then do stuff before doing the execv
[21:56] <wtay> hmm, yes
[21:57] <omega_> since fork returns 0 or 1 depending on what process you're now in
[21:57] <omega_> you just do the preload, then the execv
[21:57] <wtay> need to fork too, exec *replaces* the current process
[21:57] <omega_> right
[21:57] <omega_> you're doing this as a decoupled element, right?
[21:57] thomas (thomas at adsl-64250.turboline.skynet.be) joined #gstreamer.
[21:57] <omega_> yo
[21:58] <thomas> hi
[21:58] <wtay> omega_: details... ;:)
[21:58] <wtay> hi
[21:58] <omega_> wtay: pipefilter needs to be rewritten as a decoupled element
[21:58] <wtay> yes
[21:58] <wtay> it's basically a queue
[21:58] <omega_> yup
[21:58] <wtay> ossgst isn't a queue per se
[21:58] <omega_> no, but when it adds the OSS recording API too, it can be both
[21:59] <wtay> well, actually it can't be driven with _iterate
[21:59] <omega_> it's either a chain or get function, or both, *and* decoupled
[22:00] <thomas> I have a Studio PCTV Rave from Pinnacle and an ATI Wonder TV as video/in cards, which one should I use ?
[22:00] <omega_> problem is both of those are raw-video input
[22:00] <thomas> omega_: I know, but they'll have to do for now
[22:00] <thomas> at least until the G450 has a nice driver ;)
[22:00] <omega_> heh
[22:00] <omega_> the PCTV is a bt8x8 ?
[22:01] <thomas> I suppose, I haven't checked yet.
[22:01] <thomas> I'm still wrestling with redhat7.1 install for the moment
[22:01] <thomas> I'll take the pinnacle for now
[22:02] <thomas> they gave me an A7V mboard, it has four ide controllers... pretty nice
[22:03] <omega_> oooh
[22:03] <omega_> what proc?
[22:03] <thomas> athlon 1000
[22:03] Action: omega_ drools
[22:03] <thomas> I prefer athlon actually
[22:03] <omega_> me too
[22:03] <thomas> only has one nasty bug: after the first install you need to supply a cpu boot parameter...
[22:03] <thomas> ... seems like the athlon doesn't have a CPUID, whatever that is
[22:04] <omega_> yeah it does, it's just for some reason not well supported
[22:04] <thomas> plus for some reason the higher ultra/dma controller are second and third...
[22:04] <thomas> ...so if you put your main drive on that it ends up as hde... 
[22:05] <thomas> ... unless you supply some other params as well
[22:05] <omega_> yup, nothing new there
[22:05] <omega_> yay.  it took 2 days to get the camera,switch from CA to OR
[22:05] <thomas> and for some reason the redhat71 cd, just before installing packages, fails to recognize the disc !
[22:06] <omega_> so I won't get the thing today, it'll be Monday before my network works
[22:06] <thomas> so I'm first installing redhat6.2
[22:06] <omega_> ick
[22:06] <omega_> I'd put the disk on the first controller, and move it later
[22:06] <omega_> use a couple of boot floppies to be safe when moving it
[22:07] <thomas> omega_: not sure about that.  I mean it probably works, but ...
[22:07] <omega_> I've done it
[22:07] <thomas> I'm also trying to get two bootable root partitions, so I can switch from devel system to clean system
[22:07] <omega_> hah, I'd do more than that
[22:07] <thomas> besides, I wanted to try the hard drive install
[22:07] <omega_> root *and* user
[22:07] <thomas> omega_: what more would you do ?
[22:07] <omega_> but just put them all on one filesystem each
[22:07] <omega_> I had 4 on one machine at one time
[22:08] <omega_> and actually used most of them at various times
[22:08] <omega_> what disk do you have?
[22:08] <thomas> seagate, 30 GB
[22:08] <omega_> hmm
[22:08] <thomas> but I have a 40 GB half filled with mp3
[22:08] <omega_> you can spare 6-8gb for 3-4 /'s
[22:08] <omega_> for devel
[22:08] <omega_> I'd do 3 myself
[22:09] <thomas> ok, but why would you have so many devel's ?
[22:09] <omega_> in case
[22:09] Action: omega_ works in parallel...
[22:09] <thomas> what do you use then ? usermodelinux or vmware or something ?
[22:10] <thomas> you see, the machine will be at the tv, no screen or nothing.
[22:10] <thomas> doesn't make much sense then
[22:10] <omega_> hmm, yeah
[22:10] <omega_> I dunno, it's your box <g>
[22:10] <thomas> heh
[22:10] <taaz> omega_: what were you trying to do the other day that needed 525MHz and you only have 500?
[22:11] <thomas> I'm going to try to only make rpm's from the devel box to use on the main box
[22:11] <omega_> taaz: play vobs on my laptop
[22:11] <dobey> heh
[22:12] <taaz> i mentioned this on livid-mpeg2dec list and got flamed ;) 
[22:12] <omega_> oh?
[22:12] <omega_> are they offering the $$ to upgrade my laptop then? ;-)
[22:13] <taaz> http://www.linuxvideo.org/lists/livid-mpeg2dec/2001-May/msg00010.html
[22:13] <dobey> heh
[22:13] <dobey> it would be nice if they supported my hardware dvd decoder on my laptop
[22:13] <taaz> well, i didn't mention you were doing audio too...
[22:14] <omega_> um, yeah
[22:14] <omega_> I have every hardware-level optimization turned on (yuv overlay)
[22:15] <taaz> so what stream is it?  i'll respond and clear up the confusion with some hard details ;)
[22:15] <omega_> why exactly is he even talking about hdtv ??
[22:15] <dobey>     Multimedia controller: C-Cube Microsystems Cinemaster C 3.0 DVD Decoder (rev 2).
[22:15] <dobey> mmm
[22:15] <dobey> i wish something supported that
[22:15] <omega_> I'm playing a direct rip from the matrix DVD, the bullet-dodging scene shown on gstreamer.net
[22:15] <omega_> with ac3dec of first channel
[22:16] <omega_> things get better when I add queues before the audio and video sinks
[22:16] <omega_> but that's just because there are enough spare cycles at specific points, if the scene were longer, it'd lose again
[22:18] <thomas> anyone know how to tell the kernel with startup params to ignore some of the ide controllers ?
[22:19] <omega_> not off the top of my head.  see /usr/src/linux/Documentation/...
[22:28] steveb (steveb at node1ee06.a2000.nl) left irc: [x]chat
[22:32] <thomas> grrr... redhat... can anyone explain to me why redhat boots from a perfect cd, starts the install, then ends saying "please insert your redhat cd ???"
[22:32] <omega_> no idea. smack it around a little <G>
[22:34] <thomas> I did.  I threw the first install CD three flights of stairs down.
[22:34] <thomas> still doesn't work though
[22:34] <omega_> hmmm, I sense a connection here....
[22:35] <omega_> option: shove the hd,cd in another machine, install, and move the hd back to the new machine
[22:35] <omega_> in case there's something odd about the machine
[22:35] <thomas> yeah... but I need to leave for a bachelor's party.
[22:35] <thomas> decisions decisions ;)
[22:35] <omega_> oh
[22:37] Action: wtay watches gstreamer fork and execvp realplayer
[22:39] <Uraeus> the enable-gdkpixbuf option in configure, what does it do?
[22:39] <Uraeus> (except the obvious)
[22:39] <Uraeus> :)
[22:39] <wtay> Uraeus: nothing it can go
[22:39] <wtay> unused
[22:39] <Uraeus> ah, thanks
[22:40] <Uraeus> would it have any value if I tried writing a GStreamer 0.2.0 roadmap?
[22:41] <wtay> good idea
[22:41] <omega_> yup
[22:41] Action: omega_ waits for pbd's reply...
[22:42] Action: wtay is about to LD_PRELOAD a plugin before execle'ing realplayer
[22:42] thomas (thomas at adsl-64250.turboline.skynet.be) left irc: Ping timeout for thomas[adsl-64250.turboline.skynet.be]
[22:43] <taaz> omega_: what are you expecting? "hmmm yeah, i'm dropping everything for gstreamer!"
[22:43] dobey (dobey at dreadnought.ximian.com) left irc: Ping timeout for dobey[dreadnought.ximian.com]
[22:43] <omega_> taaz: yes ;-)
[22:45] Nick change: ajzzzz -> ajmitch
[22:48] <wtay> grr, LD_PRELOAD does not do lazy binding...
[22:50] dobey (dobey at dreadnought.ximian.com) joined #gstreamer.
[22:53] sienap (synap at ipc379c026.dial.wxs.nl) joined #gstreamer.
[22:53] <sienap> hi guys
[22:53] <sienap> hej wtay..
[22:53] <sienap> and girls ic :)
[22:53] <dobey> heh
[22:53] <dobey> mayam is not here
[22:53] <wtay> yo
[22:54] <dobey> she doesn't love me :~(
[22:54] <sienap> dobey he goh :)
[23:08] Action: omega_ is trying again to trace through the mixer iterate() problem
[23:08] <dobey> heh
[23:29] <omega_> ah, I found the problem
[23:29] <omega_> mad doesn't seem to obey COTHREAD_STOPPING
[23:29] <omega_> mad_decoder_run just keeps going
[23:29] <ChiefHighwater> details. details 8-]
[23:30] <ChiefHighwater> ...get a rope.
[23:32] ChiefHighwater (paul at temple-baptist.com) got netsplit.
[23:32] omega_ (omega at omegacs.net) got netsplit.
[23:32] wtay (wim at cable-195-162-214-190.upc.chello.be) got netsplit.
[23:32] Uraeus (cschalle at c224s9h5.upc.chello.no) got netsplit.
[23:34] omega_ (omega at omegacs.net) returned to #gstreamer.
[23:34] ChiefHighwater (paul at temple-baptist.com) returned to #gstreamer.
[23:35] <omega_> I've added a flag GST_ELEMENT_NO_ENTRY that will mark misbehaving plugins like this
[23:35] <omega_> there was already a FIXME comment in the source to add it, so...
[23:36] wtay (wim at cable-195-162-214-190.upc.chello.be) returned to #gstreamer.
[23:36] Uraeus (cschalle at c224s9h5.upc.chello.no) returned to #gstreamer.
[23:36] #gstreamer: mode change '+o wtay' by ChanServ!s at ChanServ
[23:36] #gstreamer: mode change '-o wtay' by wtay!wim at cable-195-162-214-190.upc.chello.be
[23:36] <omega_> I've added a flag GST_ELEMENT_NO_ENTRY that will mark misbehaving plugins like this
[23:36] <omega_> there was already a FIXME comment in the source to add it, so...
[23:36] <wtay> omega_: too bad I need a helper .so too..
[23:36] <omega_> oh?
[23:37] <wtay> LD_PRELOAD-ing the ossgst.so plugin yields unresolved symbols because libgst.so is not loaded
[23:37] <omega_> ick
[23:37] <omega_> so you have to have a .so with a small known API to the top-half...
[23:37] <wtay> so it seems yes
[23:38] <wtay> preload that one and use pipes to communicate
[23:38] <omega_> and eventually shm and bufferpools
[23:38] <wtay> omega_: yup, that would be an optimalisation
[23:39] <wtay> now the prob is: whats the path to the .so file...
[23:39] <omega_> ick
[23:39] <wtay> dobey: maYam is watching "the omen"
[23:39] <omega_> can you query the pluginfactory for its path?
[23:39] <wtay> omega_: it's not a plugin
[23:39] <dobey> wtay: heh
[23:39] <omega_> gstoss is
[23:39] ChiefHighwater (paul at temple-baptist.com) got netsplit.
[23:39] omega_ (omega at omegacs.net) got netsplit.
[23:40] Action: dobey blows a kiss to mayam
[23:40] ChiefHighwater (paul at temple-baptist.com) returned to #gstreamer.
[23:40] omega_ (omega at omegacs.net) returned to #gstreamer.
[23:40] #gstreamer: mode change '+o wtay' by ChanServ!s at ChanServ
[23:40] <wtay> omega_: I used the plugin repo to locate the gstoss plugin and use that path to locate the helper .so
[23:41] <omega_> right
[23:41] #gstreamer: mode change '-o wtay' by wtay!wim at cable-195-162-214-190.upc.chello.be
[23:41] <wtay> omega_: good enough?
[23:41] <omega_> yup
[23:41] <omega_> the only way
[23:41] <omega_> it also has the property of guaranteeing that hte helper .so matches the plugin
[23:41] <wtay> I had to fix gstplugin.c to set the filename var *before* calling plugin_init though
[23:42] <omega_> heh
[23:44] <taaz> heh... "we have ALSA, AES/ardour,
[23:44] <taaz> aRts, CSL and now also gStreamer"
[23:45] <taaz> i think that ordering is wrong...  (from a lad post)
[23:45] <omega_> heh
[23:45] <omega_> yeah
[23:45] <omega_> and his assumption that ardour will eat them all
[23:45] <omega_> ardour doesn't have anywhere near the infrastructure needed
[23:46] <omega_> gstreamer predates aes/ardour and csl...
[23:48] <Uraeus> what is the syntax to play a avi file from the command line?
[23:49] <taaz> gstmediaplay foo.avi ;)
[23:49] <Uraeus> not with the gstmediaplay, it crashes
[23:49] Nick change: taaz -> taaz-away
[23:50] <Uraeus> we can play using a pipeing syntax too can't we?
[23:51] <omega_> yes
[23:52] <wtay> Uraeus: what kind of avi is that?
[23:54] <Uraeus> wtay: it is the IBM linux commerical
[23:54] <wtay> oh
[23:54] <ChiefHighwater> cute...some idiot smurfed the whitehouse web site today
[23:54] <wtay> it used to play once.. but that was before the new videosink...
[23:55] <Uraeus> wtay: I can't get mpegs to play either
[23:55] <wtay> Uraeus: do you have Xv?
[23:55] <Uraeus> Xv? that is a Xfree extension right?
[23:56] <wtay> yup
[23:56] <Uraeus> I use RH7.1, so I think I use Xfree4.0.2
[23:57] <wtay> Uraeus: you tried with gstmediaplay <file>?
[23:57] <Uraeus> wtay: yes, core dumps instantly
[23:57] <wtay> Uraeus: no warnings?
[23:58] <Uraeus> ** CRITICAL **: file gstbin.c: line 172 (gst_bin_add): assertion `element != NULL' failed.
[23:58] <Uraeus> ** CRITICAL **: file gstelement.c: line 577 (gst_element_connect): assertion `src != NULL' failed.
[23:58] <Uraeus> ** CRITICAL **: file gstelement.c: line 326 (gst_element_get_pad): assertion `element != NULL' failed.
[23:58] <wtay> Uraeus: ok, you have Hermes?
[23:58] <Uraeus> ** CRITICAL **: file gstelement.c: line 273 (gst_element_add_ghost_pad): assertion `pad != NULL' failed.
[23:58] <wtay> Uraeus: gstreamer-inspect colorspace
[23:58] <Uraeus> wtay: yes, I installed it after we talked yesterday and rebuild gstreamer
[23:58] Nick change: ajmitch -> ajbusy
[23:59] <wtay> Uraeus: gstreamer-inspect colorspace
[23:59] <omega_> ok, I've fixed the iterate() never returns problem
[23:59] <Uraeus> hmm, it still says no such element or plugin 'colorspace'
[23:59] <wtay> omega_: cool
[23:59] <wtay> Uraeus: cd plugins/filters/colorspace and do make again
[00:00] --- Sat May  5 2001
[00:00] <omega_> but we need to build a tool that will take a plugin through its paces and test for all these things
[00:00] Action: omega_ wonders if _gst_newt_ is listing
[00:00] <omega_> er, listening
[00:00] <wtay> it is :)
[00:00] <omega_> nope
[00:00] <wtay> it/he/she
[00:00] <omega_> none of them have been put to the wiki in a long time
[00:01] <wtay> it's not realtime
[00:01] <omega_> 4/20 through 4/23
[00:01] <omega_> nothing since then
[00:01] <wtay> the script runs though...
[00:01] <omega_> it's not adding anything to the wiki
[00:02] <Uraeus> wtay: ok, i get further now
[00:02] <Uraeus> but...
[00:02] <wtay> omega_: last update was with statements from 23/4...
[00:02] <Uraeus> shmget failed:: No space left on devic
[00:02] <omega_> and there have been many since then
[00:02] <wtay> last update = yesterday
[00:02] <Uraeus> colorspace: no common format found
[00:03] <Uraeus> ** ERROR **: file xvideosink.c: line 452 (gst_xvideosink_chain): should not be reached
[00:03] <Uraeus> aborting..
[00:03] <wtay> Uraeus: ok...
[00:03] <wtay> Uraeus: xdpyinfo?
[00:03] <wtay> Uraeus: was that an mpeg?
[00:03] <Uraeus> yes
[00:04] <wtay> try xdpyinfo and look for an XVideo extension
[00:04] <Uraeus> wtay: i have it
[00:04] <wtay> strange..
[00:05] <omega_> latest INCSCHED commit requires complete rebuild because the flag count changed beyond the pre-allocated 8 (now 12)
[00:05] <wtay> Uraeus: can you send me the gstmediaplay --gst-mask=-1 <file> output?
[00:05] <Uraeus> ok
[00:05] <omega_> Uraeus: do a -register with --gst-mask=-1
[00:05] <omega_> that will print out a lot less, and show you the Xv props
[00:07] <Uraeus> hmm, get a lot of shmget failed: error 28 (No space left on device) messages, is my kernel paramets to low?
[00:07] <omega_> hmmm
[00:07] <wtay> oops
[00:07] <Uraeus> INFO:st_xvimage_init:136:m00;36 Xv: 0 adaptors available.
[00:07] <omega_> run ipcs ?
[00:08] <wtay> Uraeus: kernel 2.4.x?
[00:08] <Uraeus> wtay: yes
[00:08] <Uraeus> omega_: ipcs? if it is not something most distro's ship with the probably no
[00:08] <wtay> have "none            /var/shm        shm    defaults 0 0" in /etc/fstab?
[00:08] <omega_> Uraeus: it is
[00:09] <omega_> wtay: I don't have that....
[00:09] <wtay> it used to be required at some point...
[00:09] <Uraeus> I don't have it either
[00:09] <wtay> but it isn't anymore now I think
[00:10] <Uraeus> my setup should be pretty much a out of the box RH7.1 with the addition of the Ximian stuff
[00:10] <hadess> it is not needed but it's better to have it
[00:10] <Uraeus> only thing is that there might be some old NVIDIA commerical driver stuff in there, GLX for instance
[00:11] <omega_> the mntpoint doesn't even exist on an rh7 machine
[00:11] <Uraeus> but I do use the standard NVIDIA driver since I upgraded to 7.1
[00:11] <hadess> omega_: that'll be mkdir /var/shm =)
[00:11] <omega_> hadess: yes, but then, does rh7.1 have that dir? Uraeus?
[00:12] <Uraeus> no 7.1 doesn't
[00:12] <hadess> omega_: i have /dev/shm
[00:12] <hadess> not /var/shm ...
[00:12] <omega_> so if 7.1, which ships with 2.4.x, doesn't have a mountpoint let alone a fstab entry, it must not be required
[00:13] <hadess> it is not required, no, it's better for managing it though
[00:13] <hadess> iirc
[00:14] <Uraeus> hadess: well since RH doesn't include it I guess they disagree with you :)
[00:15] <hadess> Uraeus: re-read what i said...
[00:15] <hadess> <hadess> it is not required,
[00:15] <Uraeus> hadess: true, but I would think that if RH feelt it was better for managing it they would have set it up
[00:17] <hadess> "/dev/shm	shmfs		POSIX shared memory maintenance access" from Documentation/devices.txt
[00:17] <hadess> in the kernel...
[00:17] <Uraeus> ok, I will quit now to see if the commercial NVIDIA driver will help any, brb
[00:17] Uraeus (cschalle at c224s9h5.upc.chello.no) left irc: syntax error - user imploded
[00:21] ChiefHighwater (paul at temple-baptist.com) left irc: 
[00:22] <hadess> off to bed
[00:22] <hadess> cya
[00:22] <omega_> l8r
[00:22] <wtay> cya
[00:22] hadess (hadess at pc121-gui14.cable.ntl.com) left irc: mooooh!
[00:23] <wtay> fork command 0
[00:23] <wtay> forked 10424
[00:23] <wtay> hijacking /dev/dsp open, and taking it to GStreamer...
[00:23] <omega_> with the autoplugger, we have a livelock....
[00:23] <wtay> uhm
[00:23] <omega_> oooooh
[00:24] <wtay> did you see the how the mixer livelock happens?
[00:24] <omega_> checking
[00:24] <wtay> undef AUTOPLUG, define WITH_BUG
[00:25] <omega_> what does that do?
[00:25] <omega_> same
[00:26] <wtay> WITH_BUG runs a little typefind pipeline first
[00:26] <omega_> something's quite broken, mad switches to disksrc, which *immediately* switches to the volenv....
[00:26] <wtay> yup
[00:36] <sienap> how can i see the content of an rpm file ?
[00:36] <omega_> rpm -qlp asdf.rpm
[00:36] <omega_> or -qilp for more info
[00:36] <sienap> danke
[00:36] <sienap> :)
[00:47] Uraeus (cschalle at c224s9h5.upc.chello.no) joined #gstreamer.
[00:47] <Uraeus> hi
[00:48] <Uraeus> wtay: it turned out to be a problem with my driver, I installed the commercial NVIDIA driver and now it works
[00:48] <wtay> Uraeus: cool
[00:52] <Uraeus> wtay: ok, I was a bit fast, mpeg works somewhat, avi still not..the IBM video displays the first picture then just sound
[00:53] <Uraeus> hmm, I also have a 40MB mpeg clip which still gives me the shmget error
[00:54] <wtay> Uraeus: do you have the link to that video?
[00:54] <Uraeus> wtay: no, but if you have somewhere I can ftp it I can, don't have enough space on my own site for it
[00:54] <Uraeus> wtay: it is a rathe simple mpeg, no divx or anything
[00:55] <wtay> I though it was indeo or something
[00:55] <Uraeus> wtay: I can dcc it to you (it might be indeo, I do get the colorspace error to)
[00:56] <Uraeus> wtay: it is a funny clip with Jim Carrey and friends
[00:56] <wtay> Uraeus: hmm ok, very unlikely it'll work then
[00:56] <wtay> oh
[00:56] <Uraeus> mtvp plays it well
[00:56] <wtay> hmm
[00:56] <wtay> just mpeg?
[00:56] Nick change: taaz-away -> taaz
[00:57] <Uraeus> yes
[00:57] <wtay> Uraeus: I can't DCC
[00:58] <Uraeus> hmm, xine gets the same shared memory error
[01:00] Action: Uraeus hits himself in the head for being stupid, of course he can make it availabe on ftp, he is directly on the internet with his linux server 
[01:08] sienap (synap at ipc379c026.dial.wxs.nl) left irc: Ping timeout for sienap[ipc379c026.dial.wxs.nl]
[01:08] sienap (synap at ipc379c026.dial.wxs.nl) joined #gstreamer.
[01:09] Uraeus (cschalle at c224s9h5.upc.chello.no) left irc: Ping timeout for Uraeus[c224s9h5.upc.chello.no]
[01:09] Uraeus (cschalle at c224s9h5.upc.chello.no) joined #gstreamer.
[01:10] <Uraeus> wtay: did the upload have problems due to my network glitch?
[01:10] <Uraeus> err..download I guess it is for you :)
[01:10] <wtay> Uraeus: nope, just fine here..
[01:11] Action: wtay is hosing Uraeus's net connection :-)
[01:12] <Uraeus> which plugins are known to work/not work currently?
[01:15] <wtay> Uraeus: hard to say, most of them work somewhat, alsa is broken I think
[01:16] <taaz> Uraeus: you could write the test suite so we would know ;)
[01:17] <Uraeus> heh, well not a test suite, but I am putting togheter a wide set of files to test the different plugins etc.
[01:18] <Uraeus> maybe I can make those files into a quality assurance suite like the one Sun made for GNOME
[01:19] sienap (synap at ipc379c026.dial.wxs.nl) left irc: sienap has no reason
[01:19] <taaz> that's what a test suite will have... disksrc loc=foo.bar ! autoplug ! md5sink... and compare with known decoded values.  something like that...
[01:21] <Uraeus> well if it is just a set of test then I can make it, I thought you wanted to make a program that tested a lot of stuff
[01:22] <Uraeus> hmm, for some reason my bandwith is 'gone' :)
[01:22] <omega_> oh btw, I met someone at PLUG last night who was at GUADEC <g>
[01:23] <Uraeus> hmm, the wav plugin is borked
[01:23] <wtay> omega_: heh, small world :)
[01:23] <omega_> duh
[01:23] <omega_> Greg LeBlanc, of the LDP, lives here
[01:24] <Uraeus> ah, he is also in charge of the new GNOME packaging project
[01:24] <omega_> we kept eyeing each other, knowing that we recognized each other....
[01:24] <omega_> ah, cool
[01:24] <omega_> ok, I'll definitely have to talk to him more
[01:24] <omega_> it would be oh so ironic if he lived very close by
[01:24] <omega_> which is likely, since he biked to/from PLUG
[01:26] <omega_> doh
[01:26] <Uraeus> wtay: why can't you DCC? aren't you on a Chello cable modem just like me?
[01:26] <omega_> masq'd
[01:26] <omega_> Anna writes to the list offering to work on the ui guidelines....
[01:26] <omega_> 'And for what it's worth, I have a degree in writing.' ;-)
[01:27] <wtay> Uraeus: I'm masqed behind my firewall
[01:27] <Uraeus> wtay: cruddy solution :)
[01:28] <omega_> as opposed to... ?
[01:28] <omega_> shouldn't there be some ip_masq_irc though?
[01:28] <Uraeus> yes I use that
[01:28] <Uraeus> I can DCC and use a linux ipforwading server
[01:28] <omega_> ok, dcc something to me
[01:29] <omega_> 1KB/sec ?
[01:30] <Uraeus> omega_: ask wtay :)
[01:30] <omega_> is wtay still sucking your bw dry?
[01:30] <Uraeus> yup
[01:30] <omega_> ok, wtay: modprobe ip_masq_irc
[01:30] <wtay> omega_: not really... have to rebuild the kernel then..
[01:30] <Uraeus> omega_: which list did Anna mail to? ours?
[01:30] <omega_> usability
[01:31] <Uraeus> wtay: in rh that ip forwarding stuff is in by default
[01:32] <Uraeus> and I seem to remember that you use rh like me
[01:34] Action: Uraeus is suprised to learn that omega_ is on the useability list
[01:34] <omega_> why?
[01:34] Action: wtay can't intercept realplayers write...
[01:34] <omega_> wtay: is it mmap'd ?
[01:34] <wtay> omega_: nope
[01:34] <wtay> I have mmap hijacked too
[01:35] <Uraeus> omega_: just cause I would expect it to be an area you didn't have that much interest in
[01:35] <omega_> Uraeus: hardly.  I spent many hours a year ago trying to figure out how to make people realize it was important, set up tools, etc.  never did anything because I was busy with other stuff
[01:36] <omega_> but /me doesn't have any UI training
[01:38] <omega_> just sent Greg mail
[01:38] <omega_> wtay: according to audiooss, realplay uses SNDCTL_DSP_GETODELAY
[01:39] <omega_> if you don't do at least some of those SNDCTL's, you might have problems
[01:39] <wtay> omega_: I just print out the trafic and forward it to /dev/dsp
[01:39] <omega_> and this breaks real?
[01:39] <wtay> nope, it worls perfect but I don't see any writes
[01:40] <omega_> hmm, and you see no mmap's either?
[01:40] <wtay> no, just ioctls
[01:40] <omega_> odd
[01:40] <wtay> and open
[01:41] Action: Uraeus wonders where he can find more movie clips since he don't want to include 'cultural' movies in his test suite
[01:42] <omega_> afaik realplay8 does esd natively
[01:43] <Uraeus> it does
[01:44] <omega_> doesn't work for me, realplay wedges with half a GUI drawn
[01:44] <Uraeus> anyone got any divx encoded movies which without a 'nature channel' theme?
[01:46] Action: omega_ has no divx files
[01:47] <Uraeus> hmm, wonder if anyone has ever made a divx clip which isn't porn
[01:48] <dobey> haha
[01:48] <omega_> doh.  maillist admin at redhat's .sig: -ENOGUINNESS
[01:49] <wtay> I made one (mpeg2->divx)
[01:49] <wtay> but I lost it :(
[01:49] <Uraeus> wtay: good, don't want your home movies anyway :)
[01:50] <Uraeus> omega_: did you like the song?
[01:50] <omega_> ;-)
[01:50] <Uraeus> wtay: how is the clip download going?
[01:51] <Uraeus> omega_: I think it is a very good band, which has lot of cool songs
[01:51] <omega_> never heard of it
[01:51] <wtay> Uraeus: 4 more minutes
[01:52] <omega_> but then, I keep telling ChiefHighwater not to be surprised when I tell him "no, I havne't seen that seminal movie either"
[01:52] <Uraeus> omega_: it is a norwegian band :)
[01:53] <omega_> I figured
[01:53] <taaz> Uraeus: http://www.archive.org/ has many movies, mpeg2 and mpeg4
[01:53] Action: omega_ is very very confused by this livelock
[01:53] <omega_> it's spinning between *3* different cothreads, always switching from gst_schedule_pullfunc_proxy
[01:54] <omega_> it acts very much like someone constructed a loop
[01:54] Action: omega_ gets uber-suspicious
[01:55] <omega_> doh.  see -devel
[02:05] <Uraeus> how do I force gstmediaplay to output to esd instead of oss?
[02:05] <omega_> s/osssink/esdsink/;make
[02:05] <maYam> greetings friends and enemies
[02:05] <omega_> you care to give a count of those two classes?
[02:05] <Uraeus> omega_:urk
[02:06] <omega_> maYam: specific to the 6 people here, at least
[02:06] <Uraeus> maYam: I am like switzerland here
[02:06] <omega_> Uraeus: no one said gstmediaplay was mature <g>
[02:06] <maYam> lol Uraeus
[02:06] <dobey> my love!
[02:06] <wtay> no one said the author was mature :-)
[02:06] <maYam> ah dobey, how's life treating you lately?
[02:06] <omega_> point
[02:07] <maYam> wim godverdomme zwijgt!
[02:07] <dobey> maYam: eh, ok
[02:07] <maYam> (sorry-too mean to translate)
[02:07] <dobey> heh
[02:07] <Uraeus> hehe
[02:08] Nick change: ajbusy -> ajmitch
[02:08] <dobey> what lang is that?
[02:08] <omega_> looks dutch
[02:08] <maYam> flemish
[02:08] <omega_> oh
[02:08] <omega_> eek
[02:09] <omega_> um, I thought that was a 'dead' language? ;-)
[02:09] Action: Uraeus notices his disk working like mad and wonders if wtay is doing a rm -rf :)
[02:09] <maYam> hoho..  pretty much alive and kicking over here
[02:09] <omega_> hmm, ok
[02:10] Action: omega_ goes back to his regularly scheduled pretending to know stuff
[02:10] <wtay> Uraeus: nope, just finished mke2fs..
[02:10] <omega_> doh
[02:10] Action: dobey ignores mayam and goes back to happy mail
[02:10] <wtay> grmbl, execve works without -register but fails after a -register :(
[02:11] <maYam> dobey avoids /me cause he's scared.. :p
[02:11] <omega_> Uraeus: you know better than to run a ftpd
[02:11] <omega_> I don't even have one installed, afaict
[02:11] <Uraeus> omega_: I run ftpd and telnet and use the same password for all my user and root accounts, it is VERY secure :)
[02:11] Action: omega_ looks up Uraeus's IP
[02:11] <Uraeus> as wtay can confirm my password is also very advanced and hard to crack :)
[02:13] <wtay> Uraeus: you might be forced to change it now that I know it :) (which is a good thing)
[02:14] <Uraeus> wtay: no I trust in God and Wtay so I should be safe :)
[02:14] Action: omega_ hands Uraeus a clue
[02:15] Action: Uraeus doesn't know what to do with it
[02:15] <omega_> it's really easy, they did it in one of the Star Trek movies:
[02:15] <omega_> put it in your spacesuit helmet, and seal the helmet on
[02:16] <Uraeus> hehe
[02:17] Nick change: ajmitch -> ajbusy
[02:18] Action: wtay has changed Uraeus's password just for fun
[02:18] <wtay> ^ root passwd ^
[02:19] <omega_> Uraeus: here's a hint: linux single
[02:19] <wtay> init=/bin/sh time again <g>
[02:19] <omega_> again??
[02:21] Action: wtay telnets to 'thebox'
[02:21] <Uraeus> hmm
[02:23] <wtay> Uraeus: what's
[02:25] <Uraeus> wtay: my workstation
[02:25] <wtay> no telnet?
[02:25] <Uraeus> think so, unless RH has disabled it by default in 7.1
[02:26] <wtay> must be then.. :(
[02:26] <wtay> oh well
[02:30] dobey (dobey at dreadnought.ximian.com) left irc: goodbye sweetheart
[02:34] <Uraeus> hmm, is libsndfile and audiofile to libraries which try to do the same thing?
[02:34] <omega_> probably
[02:34] Nick change: omega_ -> omega_dinner
[02:41] <Uraeus> how do I use a xmms plugin under gstreamer?
[02:49] <wtay> ./gstreamer-launch  XMMS_INPUT_mpeg_layer_1/2/3_player_1.2.4 location=/opt/data/mp3/files.cgi ! osssink
[02:49] <wtay> use gstreamer-inspect xmms to find the plugin name
[02:52] <Uraeus> wtay: [cschalle at localhost cschalle]$ gstreamer-launch XMMS_INPUT_libsndfile_input_plugin_1.0pre6 location=/home/cschalle/melissa_talking_about_sabrina.au ! osssink
[02:52] <Uraeus> INFO:00;37 Initializing GStreamer Core Library
[02:52] <Uraeus> Gdk-WARNING **: shmget failed: error 28 (No space left on device)
[02:52] <Uraeus> INFO:00;37 CPU features: (c0c1f9ff) MMX 3DNOW MMXEXT 
[02:52] <Uraeus> Segmentation fault (core dumped)
[02:52] <Uraeus> any idea why?
[02:52] <wtay> no idea...
[02:55] <taaz> welcome to the wonderful world of you-need-to-use-gdb
[02:57] <Uraeus> hmm, sounds cumbersome
[03:04] <Uraeus> wtay: any idea why my mpeg doesn't work now?
[03:04] <wtay> Uraeus: the shmget failure?
[03:05] <Uraeus> wtay: no the mpeg you downloaded?
[03:05] <wtay> oh, Will look at it now...
[03:05] <Uraeus> the shmget I always get, but most stuff play anyway
[03:05] <wtay> plays perfect here
[03:05] <Uraeus> so I don't think the shmget is a 'problem', or maybe it is for bigger files
[03:05] <Uraeus> shite
[03:06] Action: Uraeus goes over to bugzilla.redhat.com
[03:08] <Uraeus> aargh, zarro bugs found
[03:08] <wtay> hmm
[03:10] <wtay> but some mpeg do play?
[03:11] <Uraeus> yes, smaller ones do
[03:11] <Uraeus> don't have any other that bif
[03:11] <Uraeus> don't have any other that big
[03:11] <Uraeus> and it plays with mtvp
[03:11] <wtay> weird..
[03:11] <Uraeus> but xine has the same error as gstmediaplay
[03:12] <wtay> did you try to add the /var/shm to fstab?
[03:12] <Uraeus> no, but according to some posts I found 2.4.0 uses /dev/shm, which I have
[03:12] <wtay> is it mounted?
[03:13] <Uraeus> probably not
[03:13] <wtay> mount /dev/shm
[03:14] <Uraeus> need to add it to fstab then I guess, hmm
[03:16] <Uraeus> aargh, fs type devshm not supported by kernel
[03:17] <Uraeus> wtay: any idea how a fstab entry should look for this?
[03:17] <taaz> tmpfs/dev/shmtmpfsdefaults0 0
[03:17] <taaz> oops...
[03:18] <taaz> tmpfs   /dev/shm    tmpfs  defaults  0 0
[03:18] <Uraeus> ok, thnx
[03:18] <taaz> for 2.4.4 at least
[03:19] <wtay> none            /var/shm        shm    defaults 0 0
[03:19] <wtay> that's what I have...
[03:19] <taaz> for 2.4.4?
[03:20] <wtay> yup
[03:20] <Uraeus> the wtay worked for me
[03:20] <Uraeus> version
[03:21] <Uraeus> not that it removed my shmget messages
[03:21] <wtay> hmm
[03:21] <wtay> any indication that a disk is full?
[03:21] <Uraeus> no, far from it
[03:22] <wtay> strange..
[03:22] <wtay> Uraeus: can you send me the --gst-mask=-1 debug output then?
[03:24] <Uraeus> ok
[03:25] <Uraeus> sent
[03:28] <wtay> Uraeus: looks like the shmget is the culprit
[03:30] <Uraeus> hmm, well I am planing on a complete reinstall anyway to switch to XFS so I check to see if the problem persists then
[03:30] <taaz> use 2.4.4 with CONFIG_TMPFS set and follow directions in CONFIG_TMPFS help ;)
[03:30] <taaz> which is where i got that fstab line from
[03:36] <Uraeus> hmm, same shite with the mplayer, aargh hate troublesome shite
[03:39] Uraeus (cschalle at c224s9h5.upc.chello.no) left irc: Ping timeout for Uraeus[c224s9h5.upc.chello.no]
[03:43] <taaz> bah... make dist failed
[03:55] Nick change: maYam -> maYam_ZzZz
[03:55] <maYam_ZzZz> night night everyone
[03:55] Nick change: wtay -> wtay-zZz
[03:55] <wtay-zZz> cya all
[03:56] <maYam_ZzZz> you should replace zZz with grrrauwn
[03:57] <wtay-zZz> ZzZz... uh?
[03:57] <wtay-zZz> snoar, snoar...
[03:57] <maYam_ZzZz> indd
[04:59] Nick change: ajbusy -> ajmitch
[05:12] arik (arik at adsl-64-174-42-2.dsl.snfc21.pacbell.net) joined #gstreamer.
[05:16] <omega_dinner> yo
[05:16] Nick change: omega_dinner -> omega_
[05:18] <arik> lo
[05:29] <arik> damnit
[05:34] <omega_> ?
[05:34] <arik> it's core dumping atm ;-)
[05:34] <omega_> oops
[05:34] <arik> so is the gstmediaplay test program actually
[05:35] <omega_> welcome to the club ;-(
[05:35] <arik> heh
[05:35] <arik> ok that's better
[05:35] <arik> no more warnings, not just nothing shows up
[05:41] <taaz> omega_: filter dir question... all the Makefile.am's have EXTRA_DIST = README but no READMEs except for passthrough.  this breaks 'make dist' and i'm not sure if the intent is to add READMEs or that should be removed.
[05:41] Action: taaz notes that wasn't a question
[05:46] <omega_> hrm, that's because passthrough was the prototype for them
[05:46] <omega_> remove the extra_dist from those
[05:51] <taaz> yup, that's what i did
[06:09] <taaz> hmm... typo in my cvs commit... whoops
[06:14] <arik> argh!
[06:14] <taaz> make dist is busted in the arts dir too.  i have no idea what mcopidl is/does but it's not finding artsflow.idl on a make dist despite the fact that i've built the plugin.  never tested it though...
[06:16] <omega_> for some reason the makefile ignores the rule I put in
[06:16] <omega_> but you will need to add the idl to EXTRA_DIST
[06:17] <arik> omega_: i bet i am doing something silly here
[06:18] <omega_> ?
[06:19] <taaz> omega_: don't take the bet... ;)
[06:20] <arik> omega_: currently everything runs but no video frames actually show
[06:24] <taaz> ok, where is artsflow.idl supposed to be for this to work?  debian has:
[06:24] <taaz> libarts-dev: /usr/include/kde/arts/artsflow.idl
[06:24] <omega_> taaz: no idea
[06:25] <omega_> arik: if you print out debug messages, does the videosink indicate that it's showing frames?
[06:25] <taaz> you have /usr/local hardcoded stuff there...  
[06:25] <omega_> taaz: yes, because arts doesn't have any mechanism to find it
[06:25] <taaz> is there a arts-config or something?
[06:25] <omega_> this is KDE, remember
[06:26] <taaz> ahh... there is.  artsc-config

More information about the gstreamer-devel mailing list