[gst-devel] RE: XVID plugin and one question

Ronald Bultje rbultje at ronald.bitfreak.net
Wed May 1 10:23:12 CEST 2002

Hi Gianluca,

On Wed, 2002-05-01 at 11:07, g.insolvibile at cpr.it wrote:
> Hello again and thanks to Andy, Jeremy and Ronald for their kind
> answers. You are all basically suggesting the same thing, i.e. that
> the problem is with caps negotiation. I tried having a look at that
> with no success... so I definitely need your help! ;-)

Seeing the website, you're still not using a thread.

gst-launch --gst-mask=-1 filesrc location=xXx_DivX.divx ! avidemux
video_00! xviddec ! disksink location=test > errors.log 2>& 1

Please use the following command:

gst-launch --gst-mask=-1 filesrc location=xXx_DivX.divx ! avidemux
video_00! { queue ! xviddec ! disksink location=test } &> errors.log

The log simply says that xviddec's sink pad wasn't connected to
avidemux' video_00 pad, which is true for on-demand pads which are not
connected to a queue. So please use a queue and try again ;-).


-   .-.
-   /V\    | Ronald Bultje <rbultje at ronald.bitfreak.net>
-  // \\   | Running: Linux 2.4.18-XFS and OpenBSD 3.0
- /(   )\  | http://ronald.bitfreak.net/
-  ^^-^^

More information about the gstreamer-devel mailing list