[gst-devel] Streaming Problem...

CCiongoli at viewpoint.org CCiongoli at viewpoint.org
Thu Apr 24 22:32:04 CEST 2003

Hello.  I am running GStreamer 0.6.1 on RedHat Linux 8.0.  I have used APT
and installed the gstreamer-universe so I could just have everything ready
at my fingertips.  I am both using commandline and writing code.  Right now
I am trying to get one computer to stream to another, however it is not
working like it should.  On the client computer, I have run this in the
command line: "gst-launch udpsrc ! mad ! osssink".  The client runs the
pipeline and sits and waits.  I then go to the server and run "gst-launch
filesrc location=a.mp3 ! udpsink host=".  The server begins
streaming and I here the song beginning to play on the client.  All of a
sudden (after about 1-2 seconds) the server pipeline stops and the song
playing cuts off with a sound as if you were pulling a vinyl off a
phonograph while it was playing.  The same thing happens when I enter this
into C code, compile, and run the program.  I then tried running this line
on the server "gst-launch filesrc location=a.mp3 ! mp3parse ! udpsink
host=" and the same thing happens again (the song plays onteh
client for about a half a second longer).  Has anyone had this problem?
What is it that I am doing wrong?  Do I need to run the commandline/code on
the server first before I run the client's?  Thanks in advance.


More information about the gstreamer-devel mailing list