EDIT: [gst-devel] Streaming Problem...

CCiongoli at viewpoint.org CCiongoli at viewpoint.org
Fri Apr 25 10:45:14 CEST 2003

I tried running the server line first, makes no difference at all.  This is
what is returned:

[root at localhost test]# gst-launch filesrc location=a.mp3 ! mp3parse !
udpsink host=
INFO ( 1972: 0) Initializing GStreamer Core Library version 0.6.0
INFO ( 1972: 0) CPU features: (00000000) MMX SSE
registry: loaded user_registry in 0.000151 seconds
registry: loaded global_registry in 0.174187 seconds
GStreamer-INFO: 0 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)
RUNNING pipeline
execution ended after 10121 iterations (sum 306369000 ns, average 30270 ns,
min 2000 ns, max 13244000 ns)
GStreamer-INFO: 828 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)
[root at localhost test]#

Anyone know what's going on?  Thanks. 

-----Original Message-----
From: CCiongoli at viewpoint.org
To: gstreamer-devel at lists.sourceforge.net
Sent: 4/24/03 10:27 PM
Subject: [gst-devel] Streaming Problem...

Hello.  I am running GStreamer 0.6.1 on RedHat Linux 8.0.  I have used
and installed the gstreamer-universe so I could just have everything
at my fingertips.  I am both using commandline and writing code.  Right
I am trying to get one computer to stream to another, however it is not
working like it should.  On the client computer, I have run this in the
command line: "gst-launch udpsrc ! mad ! osssink".  The client runs the
pipeline and sits and waits.  I then go to the server and run
filesrc location=a.mp3 ! udpsink host=".  The server begins
streaming and I here the song beginning to play on the client.  All of a
sudden (after about 1-2 seconds) the server pipeline stops and the song
playing cuts off with a sound as if you were pulling a vinyl off a
phonograph while it was playing.  The same thing happens when I enter
into C code, compile, and run the program.  I then tried running this
on the server "gst-launch filesrc location=a.mp3 ! mp3parse ! udpsink
host=" and the same thing happens again (the song plays
client for about a half a second longer).  Has anyone had this problem?
What is it that I am doing wrong?  Do I need to run the commandline/code
the server first before I run the client's?  Thanks in advance.


This sf.net email is sponsored by:ThinkGeek
Welcome to geek heaven.
gstreamer-devel mailing list
gstreamer-devel at lists.sourceforge.net

More information about the gstreamer-devel mailing list