[gst-devel] good point from gnomedesktop

David I. Lehn dlehn at vt.edu
Wed Jan 8 10:12:09 CET 2003

* Thomas Vander Stichele <thomas at urgent.rug.ac.be> [20030108 12:41]:
> My idea is to change connect to chain.  I like it, it's shorter, and it 
> makes sense.  so ...
> _connect          -> _chain
> _connect_many     -> _chain_many
> _connect_filtered -> _chain_filtered
> _disconnect       -> _unchain_from
> _disconnect_many  -> _unchain_many

Well, if we're going to discuss a totally new word...  There are other
short options as well: connect, chain, link, attach, join, unite,
couple, glue, etc etc.

Don't forget that GstPad also has _connect*/_disconnect*.  Those should
be changed as well for the same reasons.


More information about the gstreamer-devel mailing list