[gst-devel] Problem with recording audio

Markus Westergren markus.westergren at orexis.se
Wed Jan 29 02:48:01 CET 2003

Hi Leif,

On Tuesday 28 January 2003 18:14, you wrote:
> Hi Markus -
> We've been working on the ALSA plugins in CVS the last couple of weeks.
> They still need a lot of love, as you've discovered. :)
> > So it seems like hw:0,0 and hw:1,0 is the right devices and that they are
> > opened correctly but there are some problem setting the sample rate.
> >
> > How can I choose which card I wan't to use with the gstalsa plugin?
> You're using the correct property there for setting the device. I suggest
> you try using some different values for the "rate" parameter, suchly :
> gst-launch alsasrc rate=48000 device=hw:0,0 ! wavenc ! filesink location
> =/tmp/tst.wav
Added the rate parameter to the command line and if I use rate=48000 there 
are no warning about not being able to set the rate parameter. I always have 
to specify rate=48000 if I don't use device=default. The device is opened and 
data is flowing through the pipeline. What is the difference between default 
and the hw:?,? device names. Is'nt the default device only an alias for one 
of my cards?

How do I do if I want to use another samplerate? I can't enter any samplerate 
other than 48000 Hz (the default device supports both 44100 and 48000). In my 
applicaton I have no use for 48000 Hz samplerate, 22050 Hz is enough. I want 
to code the audio into mp3 or ogg and then stream it via icecast/icecast2.

> Or if you haven't done so you could try to mess around with your
> ~/.asoundrc a bit (but that's really a pain).
I'm not that familiar with this configuration file. Have added a definition 
for a device but if i use this name i get the same error as if I use hw:0,0. 
Have tried to look for dokumentation on how to use this but without much 

> If you keep coming up against this, could you please file a bug at
> bugzilla.gnome.org ? Thanks !
> leif



More information about the gstreamer-devel mailing list