[gst-devel] Driver bug recognized + Internal GStreamer error pad problem, File a Bug

vishwanath H.G visuu2003 at yahoo.com
Wed Dec 22 04:54:16 CET 2004


When try to play mp3 file using mad plugin, i am facing following issue.
And my oss-audio driver does not round rates correctly,it only  support defined rates like such as 8,16,32,44.1,48Khz.
If I request for audio driver other than these defiined rates, it says "Invalid sample rates" and then gstreamer is failed to negotiate the rates.
This is happening in the gst-plugins-0.8.6/sys/oss/gstosselement.c
How do I come out this problem? Where can I modify the Gst-plugins/Gstreamer such that it reuest only defined rates.Correct me if I am wrong. 
# ./gst-launch filesrc location=vis1.mp3 ! mad ! osssink --gst-debug-level=1
RUNNING pipeline ...
Invalid Sample Rate 1000 requested
Invalid Sample Rate 100000 requested
ERROR (0x16a50 -Invalid Sample Rate 28000 requested
 0:21:18.370092000)             oss(  222) gstosselement.c(1217):gst_osselement_
rate_probe_check: Driver bug recognized (driver does not round rates
correctly).  Please file a bug report.
ERROR (0x16a50 - 0:21:23.020126000)        GST_PADS(  222)
gstpad.c(2490):gst_pad_set_explicit_caps:<mad0> failed to negotiate (try_set_caps with "audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16,
depth=(int)16, rate=(int)44100, channels=(int)2" returned REFUSED)
ERROR: from element /pipeline0/mad0: Internal GStreamer error: pad problem.File a bug.
Additional debug info:
gstpad.c(2490): gst_pad_set_explicit_caps: /pipeline0/mad0:
failed to negotiate (try_set_caps with "audio/x-raw-int,
endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100,channels=(int)2" returned REFUSED)
ERROR (0x16a50 - 0:21:23.050097000)       scheduler(  222) gstoptimalscheduler.c
(2609):gst_opt_scheduler_iterate:<GstOptScheduler at 0x8b220> in error
state Execution ended after 4 iterations (sum 4630007000 ns, average
1157501750 ns, min 11000 ns, max 2939986000 ns).
Let me know your thoughts....
Waiting for your reply.

Mark Dezelon <markdezelonti at yahoo.com> wrote:
vishwanath H.G wrote:
> 5. Run "gst-register" on target
> # gst-register
> Rebuilding global_registry
> (/usr/local/fs/vishwa/var/cache/gstreamer-0.8/registry.xml) ...
> Rebuilding user_registry (/root/.gstreamer-0.8/registry.xml) ...
> Loaded 0 plugins with 0 features.

I concur with everything Thomas wrote.

Also, if gst-register is loading zero plugins, then you
should fix that problem before moving on to the mad plugin.
I'm also compiling GStreamer for the ARM, and I've just
gotten it to compile and execute.

I ran "gst-register --gst-debug-level=5" to verify that it
found the normal plugins. In my case, the plugins were
found, but each plugin wasn't recognized as a GStreamer
plugin. To make a long story short, when I compiled glib for
the arm, I supplied "glib_cv_uscore=yes" in the autogen< BR>file; turns out I really wanted "glib_cv_uscore=no". After
reconfiguring and recompiling glib, GStreamer worked as

Other pages that helped me:

* glib-2.4.8/docs/reference/glib/html/glib-cross-compiling.html (from
within glib)

Once "gst-register" loads plugins and "gst-inspect fakesrc"
returns expected information, then you can focus on loading
the mad plugin.

Just some thoughts; hope that helps.

-- Mark Dezelon

Do you Yahoo!? 
Meet the all-new My Yahoo! - Try it today! 

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
gstreamer-devel mailing list
gstreamer-devel at lists.sourceforge.net

Do you Yahoo!?
Yahoo! Mail - Easier than ever with enhanced search. Learn more.

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20041222/dc6cbf0f/attachment.htm>

More information about the gstreamer-devel mailing list