[gst-devel] ERROR: from element /pipeline0/mad0: Internal GStreamer error: pad problem.

vishwanath H.G visuu2003 at yahoo.com
Fri Dec 17 05:07:03 CET 2004

I followed the steps told by you and thomas and now i am able to load plugins.
Actually it was problem  while compiling glib-2.4.6(I supplied "glib_cv_uscore=yes" in the autogen file), Then I recompiled it by supplying "glib_cv_uscore=no" I was able to load plugins .

When try to play mp3 file using mad plugin, i am facing following error
But i am able to play using madplay tool.
# ./gst-launch filesrc location=vis1.mp3 ! mad ! osssink
RUNNING pipeline...............
Invalid Sample Rate 1000 requested
Invalid Sample Rate 100000 requested
Invalid Sample Rate 28000 requested
ERROR: from element /pipeline0/mad0: Internal GStreamer error: pad problem.
File a bug.
Additional debug info:
gstpad.c(2490):gst_pad_set_explicit_caps: /pipeline0/mad0:
failed to negotiate (try_set_caps with "audio/x-raw-int,endianness=(int)1234, sighned=(boolean)true, width=(int)16,depth=(int)16, rate=(int)44100,channels=(int)2" returned REFUSED) 
Excution ended after 4 iterations (sum 5210009000 ns, average 1302502250 ns, min 13000 ns, max 329993000 ns).
# madplay vis1.mp3
-------->It able to play
Could you point me to the error here?
 Let me know your thoughts....

Mark Dezelon <markdezelonti at yahoo.com> wrote:
vishwanath H.G wrote:
> 5. Run "gst-register" on target
> # gst-register
> Rebuilding global_registry
> (/usr/local/fs/vishwa/var/cache/gstreamer-0.8/registry.xml) ...
> Rebuilding user_registry (/root/.gstreamer-0.8/registry.xml) ...
> Loaded 0 plugins with 0 features.

I concur with everything Thomas wrote.

Also, if gst-register is loading zero plugins, then you
should fix that problem before moving on to the mad plugin.
I'm also compiling GStreamer for the ARM, and I've just
gotten it to compile and execute.

I ran "gst-register --gst-debug-level=5" to verify that it
found the normal plugins. In my case, the plugins were
found, but each plugin wasn't recognized as a GStreamer
plugin. To make a long story short, when I compiled glib for
the arm, I supplied "glib_cv_uscore=yes" in the autogen
file; turns out I really wanted "glib_cv_uscore=no". After
reconfiguring and recompiling glib, GStreamer worked as

Other pages that helped me:

* glib-2.4.8/docs/reference/glib/html/glib-cross-compiling.html (from
within glib)

Once "gst-register" loads plugins and "gst-inspect fakesrc"
returns expected information, then you can focus on loading
the mad plugin.

Just some thoughts; hope that helps.

-- Mark Dezelon

Do you Yahoo!? 
Meet the all-new My Yahoo! - Try it today! 

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
gstreamer-devel mailing list
gstreamer-devel at lists.sourceforge.net

Do you Yahoo!?
 Yahoo! Mail - Easier than ever with enhanced search. Learn more.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20041217/5f08bb9e/attachment.htm>

More information about the gstreamer-devel mailing list