[gst-devel] RE: elegancy (was: RE: win32 build works fine)

Benjamin Otte in7y118 at public.uni-hamburg.de
Tue Jun 22 06:09:01 CEST 2004

On Fri, 18 Jun 2004, Marc VanDaele wrote:

> Hello Benjamin,
> Wouldn't it be possible to remove GST_CAT_DEFAULT *variable*.
> Having both a variable and a define with the same name is confusing.
The variable is there for three reasons:
1) legacy code (mostly inside gst-plugins) that wasn't cleaned up yet and
still doesn't know about debugging categories.
2) rapid prototyping: You can easily do s/printf/GST_DEBUG/ with your
debugging output while developing and not care about it anymore.
3) it's easier for our users if they don't get errors. "I got errors with
GST_DEBUG, therefore it sucks and I use ptintf again" is not what I want


More information about the gstreamer-devel mailing list