[gst-devel] Newbe Win32: gst-launch fails

Steve Lhomme steve.lhomme at free.fr
Thu Nov 25 04:48:02 CET 2004

Hi Larry,

Larry Berlinski a écrit :
> I'm at a loss ...
> I've attempted to run gst-launch using a few of the sample test commands
> e.g., 
> gst-launch fakesrc num_buffers=5 ! fakesink
> gst-launch sinesrc ! fakesink
> ... and others, all of them fail at the same spot, in _file.c

I've only tried very few command-lines and some didn't work. It was just 
to check that everything was compiled and running, but no problem free. 
Did you recompile the plugins with the up-to-date versions too ?

I don't have much time these days for the GSTreamer port as I'm already 
struggling to finish an important part of the Matroska project. But I'll 
keep an eye on GStreamer meanwhile.

> Also, I've compiled libmad-0.15.1b using MSVC++, and successfully created the libmad.lib file ... how do I get it into gstreamer so that it's recognized by gstreamer?

You have to check the gst-plugin source directory. So far only the 
'internal' plugins are compiled (ie not requiring external libraries). 
There are much more to compile in the "ext" directory. But I haven't 
worked on that part yet.

I hope it helps a bit...

More information about the gstreamer-devel mailing list