[gst-devel] Help with GStreamer-0.10 (plz don't ignore)

Edgard Lima edgard.lima at indt.org.br
Wed Dec 7 05:44:05 CET 2005

Hi Sammer,

I think u could follow this

# here look at the list of plugins that will not be built
# probabily the reason is some lib is missing
# take a look at config.log and configure.ac
make && sudo make install

gst-register doenst exist since 0.9


Sameer Naik wrote:

> hi sameer here....
> im new to gstreamer...
> i got some problem that needs some urgent attention... plz try to help
> it goes like this.
> i had installed the gstreamer-0.8 rpms on my fedora core 3, i386 
> system, and it worked well...i could rum the example in the docs and 
> test it with some modifications too...
> then since gstreamer-0.10 has been released i am interested in making 
> the switch right away. and since the rpm's aren't released at the 
> moment i decided to compile the sources my self.
> so first of all i upgraded my glib libraries.. ran configure with 
> "--prefix=/usr" option
> and then i installed gstreamer and the other stuff with the same 
> "--prefix=/usr" option..
> the pakages i've installed are:
> glib-2.6.6
> gstreamer-0.10
> gst_plugins-base-0.10.0
> gst_plugins-good-0.10.0
> gst_plugins-bad-0.10.0
> gst_plugins-ugly-0.10.0
> gst_ffmpeg-0.10.0
> i was'nt able to install the gst_python-0.10.0 pakage though...
> now heres the problem
> if i run the following command
> [root at nextbitcpu ~]# gst-inspect-0.10
> i get the following output:
> coreindexers:  memindex: A index that stores entries in memory
> coreindexers:  fileindex: A index that stores entries in file
> coreelements:  capsfilter: CapsFilter
> coreelements:  fakesrc: Fake Source
> coreelements:  fakesink: Fake Sink
> coreelements:  fdsrc: Disk Source
> coreelements:  filesrc: File Source
> coreelements:  identity: Identity
> coreelements:  queue: Queue
> coreelements:  filesink: File Sink
> coreelements:  tee: Tee pipe fitting
> coreelements:  typefind: TypeFind
> staticelements:  bin: Generic bin
> staticelements:  pipeline: Pipeline object
> and thats all...no ffmpeg,mad and so on
> even if i try
> # gst-inspect-0.10 osssink
> i get the error msg
> "No such element or plugin 'osssink'"
> and this is the same for most of the plug-ins that i used in 
> gstreamer-0.8
> i used the following commands to compile all the above mentioned sources
> ./configure --prefix=/usr
> make
> make install
> gst-register (for gstreamer-0.10)
> i cant figure out whats happening...
> i need help deperately, im sure u guys will help me out on this one
> thanks in advance
> waiting for ur replies...
> Warm Regards
> Sameer
> -------------------------------------------------------
> This SF.net email is sponsored by: Splunk Inc. Do you grep through log 
> files
> for problems?  Stop!  Download the new AJAX search engine that makes
> searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
> http://ads.osdn.com/?ad_id=7637&alloc_id=16865&op=click
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel

More information about the gstreamer-devel mailing list