[gst-devel] gst-player configure problem

Robert Osfield robert at openscenegraph.com
Sat Jan 29 02:19:27 CET 2005

Hi All,

I am looking to write a video plugin to an open source real-time graphics 
toolkit (http://www.openscenegraph.org), this will allow users to put video 
textures into their 3D worlds.  Gstreamer is on my list of libraries to 
evaluate for this task.

I spent the whole of yesterday trying to get gstreamer and associated modules 
compiled and installed, while I'm encouraged by the quality of the website 
and the aims of gstreamer, I must admit the number of external dependencies 
was a serious drawback, both w.r.t build support and compiling agains the 

I have got gstreamer-0.8.8, gst-ffmpeg-0.8.3 and gst-plugins-0.8.7 all 
compiled and installed. I also tried the cvs versions.  I also tried 
gst-editor (from CVS) and gst-player-0.8.0 and alas didn't get these 
compiling, despite as far as I'm aware installing all dependencies.  I run 
through things that might be of interest in diagnosing the problem.

One problem when running the configure on streamer-0.8.8 was, extract from ./
configure output follows :

   checking for libgnomeui-2.0... Package libart-2.0 was not found in the  
   pkg-config search path.
   Perhaps you should add the directory containing `libart-2.0.pc'
   to the PKG_CONFIG_PATH environment variable
   Package 'libart-2.0', required by 'libgnomecanvas-2.0', not found

Now I download the latest libart source code (libart-2.3.3), and did the 
usual ../configure;make;make install'd.  I'd expect all the required elements 
to be installed in default places that gstreamer could pick up on.  I can't 
find any .pc file the libart source code distribution.  What would create 
this file?

gstreamer compile ok, and I installed it.  I then compiled gst-plugins, and 
gst-ffmpeg without too many issues.

Trying to compile gst-editor comes up with the same problem as above w.r.t. 
libart-2.0.pc, so wasn't able to progress here.

Trying to compile gst-player-0.8.0, I run ./configure and get the following 

  checking for    gstreamer-play-0.8 >= 0.8.0         gstreamer-interfaces-0.8  
   >= 0.8.0   gstreamer-gconf-0.8 >= 0.8.0... Package gstreamer-gconf-0.8 was  
   not found in the pkg-config search path.
  Perhaps you should add the directory containing `gstreamer-gconf-0.8.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'gstreamer-gconf-0.8' found
  configure: error: you need gstreamer development packages installed !

I have tried running the gstreamer configure with options to compile static 
and shared libraries and compiling and installing this makes no difference.  
I have searched for gstreamer-gconf-0.8.pc and it doesn't exist in either 
gstreamer-0.8.8 or gstreamer from CVS.  I find plenty of other .pc in 
gstreamer distribution but not the one that gst-player is requiring:

  gstreamer> find . -name *.pc

  gstreamer-0.8.8> find . -name *.pc

I have tried really hard to get everthing installed, I have gone through an 
number of different combination, I have looked through the install docs for 
all these libraries, and frankly I am increadibly frustrated at having put so 
much effort into not even getting what should be a simple app up and running.  
Is this a build bug?  Is there something I haven't done correctly?

I can provide full configure output if required.


More information about the gstreamer-devel mailing list