[gst-devel] gst-player configure problem

Tim Müller t.i.m at zen.co.uk
Sat Jan 29 04:57:58 CET 2005

On Saturday 29 January 2005 10:22, Robert Osfield wrote:

> I spent the whole of yesterday trying to get gstreamer and associated
> modules compiled and installed, while I'm encouraged by the quality of the
> website and the aims of gstreamer, I must admit the number of external
> dependencies was a serious drawback, both w.r.t build support and compiling
> agains the dependencies.

> One problem when running the configure on streamer-0.8.8 was, extract from
> ./ configure output follows :
>    checking for libgnomeui-2.0... Package libart-2.0 was not found in the
>    pkg-config search path.
>    Perhaps you should add the directory containing `libart-2.0.pc'
>    to the PKG_CONFIG_PATH environment variable
>    Package 'libart-2.0', required by 'libgnomecanvas-2.0', not found
> Now I download the latest libart source code (libart-2.3.3), and did the
> usual ../configure;make;make install'd.  I'd expect all the required
> elements to be installed in default places that gstreamer could pick up on.
>  I can't find any .pc file the libart source code distribution.  What would
> create this file?

2.3.17 is the latest I found [1]. Often there aren't foo.pc files, but 
foo.pc.in files (and configure creates the foo.pc file then).

As Ronald already pointed out, you really shouldn't install libraries like 
that from source though, unless absolutely necessary. It might work fine in 
the short run, but you'll run into problems in the longer run. Doesn't SuSe 
ship libart and the corresponding -devel packages? Why didn't you install 

>    >= 0.8.0   gstreamer-gconf-0.8 >= 0.8.0... Package gstreamer-gconf-0.8
>    > was not found in the pkg-config search path.
>   Perhaps you should add the directory containing `gstreamer-gconf-0.8.pc'
>   to the PKG_CONFIG_PATH environment variable
>   No package 'gstreamer-gconf-0.8' found
>   configure: error: you need gstreamer development packages installed !
> I have tried running the gstreamer configure with options to compile static
> and shared libraries and compiling and installing this makes no difference.
> I have searched for gstreamer-gconf-0.8.pc and it doesn't exist in either
> gstreamer-0.8.8 or gstreamer from CVS.  I find plenty of other .pc in
> gstreamer distribution but not the one that gst-player is requiring:
>   (snip a lot)
> I have tried really hard to get everthing installed, I have gone through an
> number of different combination, I have looked through the install docs for
> all these libraries, and frankly I am increadibly frustrated at having put
> so much effort into not even getting what should be a simple app up and
> running. Is this a build bug?  Is there something I haven't done correctly?

These .pc files should get installed into $prefix/lib/pkgconfig if you do 
'make install'. If you installed from source, you'll probably find them 
in /usr/local/lib/pkgconfig. You might need to do

  export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

to make pkg-config find those .pc files (/usr/bin/pkg-config will only look 
in /usr/lib/pkgconfig by default, that's why).

Have you tried that?


[1] ftp://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3/

More information about the gstreamer-devel mailing list