[gst-devel] GstPolyBin idea and request for comments
steve at stevebaker.org
Tue Mar 8 14:08:30 CET 2005
A flag for GstController makes sense since many elements might need it,
however this sounds like a flag just for PolyBin elements which is getting
a bit specialised.
Instead of adding another flag just for PolyBin, you could just document
the naming convention for the properties so the app can introspect what
each property does, for example:
foo_global - a global property which acts on all voices
foo_voice_003 - a property which acts on voice 3 of the PolyBin
> today we've discussed the GstController (next gen dparams) on IRC and
> decided to
> add a G_PARAM_SPEC flag to mark gst_element properties as controllable.
> There is another situation where I would like to add such a flag for.
> I've written it down at:
> So I would need a flag like GST_PARAM_POLYPHONIC. I sounds most useful for
> audio, but I can imagine using it with graphical effects too.
> Are there any arguments against adding this flag?
> SF email is sponsored by - The IT Product Guide
> Read honest & candid reviews on hundreds of IT Products from real users.
> Discover which products truly live up to the hype. Start reading now.
> gstreamer-devel mailing list
> gstreamer-devel at lists.sourceforge.net
More information about the gstreamer-devel