[gst-devel] Audio over udp

M M mikel_m01 at yahoo.com
Thu Apr 20 15:54:02 CEST 2006

I am quite new to gstreamer, and I have been struggling to transmit video and audio over udp, with this pipeline

gst-launch filesrc location=MovieTra1950_3.mpeg ! decodebin name=d  ! ffmpegcolorspace ! ffenc_mpeg4 ! udpsink  port=4000 -v d. ! audioconvert ! lame ! udpsink  port=4010 -v

gst-launch udpsrc port=4000 caps="video/mpeg" ! ffdec_mpeg4 ! ffmpegcolorspace ! xvimagesink -v & gst-launch udpsrc port=4010 ! mad ! audioconvert ! osssink -v

But no audio is received  only video.

I also tried using rtp, it worked for video with this pipeline

gst-launch videotestsrc ! video/x-raw-yuv,width=176,height=144 ! ffenc_mpeg4 ! rtpmp4vpay ! rtpmp4vdepay ! ffdec_mpeg4 ! xvimagesink

But for Audio with this pipeline
gst-launch audiotestsrc ! audioconvert  ! audio/x-raw-int, width=16, channels=2, rate=48000 ! lame ! rtpmpapay ! rtpmpadepay  ! ffdec_mp3 ! osssink

gives the following error
ERROR: from element /pipeline0/audiotestsrc0: Internal data flow error.
Additional debug info:
gstbasesrc.c(1416): gst_base_src_loop (): /pipeline0/audiotestsrc0: streaming task paused, reason error

I also tried using a muxer (matroska and multipart) before transmitting over udp but it didn't work. Please how can do this, I really need this help.


Celebrate Earth Day everyday!  Discover 10 things you can do to help slow climate change. Yahoo! Earth Day
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20060420/26dba9f8/attachment.htm>

More information about the gstreamer-devel mailing list