[gst-devel] Cannot compile latest stable “good” plugins.

Tomasz Melcer liori at exroot.org
Thu Aug 3 14:48:35 CEST 2006


I have Ubuntu Dapper, regularly updated. After upgrading from Breezy, i
noticed that every music player that uses gstreamer has the same
problem: they were unable to play more than one file. After playing
first file, i have to shut down player and start it again to play 
second. I've got that with every type of file, whether it is wav, flac 
or mp3. Rhythmbox just skips the file and tries next (which also doesn't 
work), Totem-gstreamer just displays dialog with “not negotiated” 
string; quod libet is the most verbose here, I get a dialog:

Unable to play song
GStreamer was unable to load the selected song.
Element doesn't implement handling of this stream. Please file a bug.

and from the stderr:

ERROR (0x82d8118 - 0:00:04.243285000)        audioresample( 5620) 
resample_ref.c(118):resample_scale_ref: buffer_queue_pull returned NULL

That happens when trying to play second file after first one, even if 
the second one is the same file as first. Ubuntu versions for that software:

gstreamer0.10-alsa: 0.10.7-0ubuntu4
gstreamer0.10-esd: 0.10.3-0ubuntu4
gstreamer0.10-gnomevfs: 0.10.7-0ubuntu4
gstreamer0.10-plugins-base: 0.10.7-0ubuntu4
gstreamer0.10-plugins-base-apps: 0.10.7-0ubuntu4
gstreamer0.10-plugins-good: 0.10.3-0ubuntu4
gstreamer0.10-plugins-ugly: 0.10.3-0ubuntu3
gstreamer0.10-tools: 0.10.6-0ubuntu2
gstreamer0.10-x: 0.10.7-0ubuntu4
libgstreamer-plugins-base0.10-0: 0.10.7-0ubuntu4
libgstreamer0.10-0: 0.10.6-0ubuntu2
libtotem-plparser0: 1.2.0-0ubuntu3.1
libtotem-plparser1: 1.4.3-0ubuntu1
python-gst0.10: 0.10.4-0ubuntu1
quodlibet: 0.18-3ubuntu1
quodlibet-ext: 0.18-3ubuntu1
totem: 1.4.3-0ubuntu1
totem-gstreamer: 1.4.3-0ubuntu1
totem-gstreamer-firefox-plugin: 1.4.3-0ubuntu1

I found that similar bug was reported to ubuntu's bugtracker (launchpad: 
Reporter mentioned also that when trying to move “position” slider when 
rhythmbox tried to play second song results in playing small part of 
that song (about half a second, maybe less), then rhythmbox skips.

(I would report it to gstreamer, but I get lost in bugzilla. That's not 
a kind of interface for people who rarely have something to do)

I tried to diagnose the problem. Due to that the problem exists using 
three different players, I assumed that there's something wrong with 
gstreamer. Firstly, I wanted to check if I'll get the same with 
gstreamer from CVS (yesterday). I managed to compile modules: 
“gstreamer”, “gst-plugins-base”, “gst-plugins-good” and “gst-python” 
(for quodlibet). I deinstalled gstreamer debs, then installed the cvs 
version with prefix /usr, so that ubuntu versions of players will be 
able to use them without relinking. But seems that I did something 
wrong, because despite that `gst-inspect` listed many different modules 
and features, none of them were discovered by quodlibet (which lists 
available formats at the start), no player could also play anything. 
Quod libet devs said I should try last stable versions, because it might 
be that CVS sources are broken at the moment.

So I downloaded from CVS sources tagged with RELEASE-0_10_9 (gstreamer, 
gst-plugins-base), RELEASE-0_10_3 (gst-plugins-good) and RELEASE-0_10_5 
(gst-python). gstreamer and base plugins didn't make trouble, but I 
cannot get through autogen.sh in “good” plugins:

tomasz:~/Projekty/gstreamer/gst-plugins-good% ./autogen.sh 

+ check for build tools
   checking for autoconf >= 2.52 ... found 2.59, ok.
   checking for automake >= 1.6 ... found 1.7.9, ok.
   checking for autopoint >= 0.11.5 ... found 0.14.5, ok.
   checking for libtoolize >= 1.5.0 ... found 1.5.22, ok.
   checking for pkg-config >= 0.8.0 ... found 0.20, ok.
+ checking for autogen.sh options
   This autogen script will automatically run ./configure as:
   ./configure --enable-maintainer-mode --enable-gtk-doc
   To pass any additional options, please specify them on the ./autogen.sh
   command line.
patching file po/Makefile.in.in
+ running autopoint --force ...
Copying file mkinstalldirs
patching file po/Makefile.in.in
+ running aclocal -I m4 -I common/m4 ...
+ running libtoolize --copy --force...
+ running autoheader ...
autoheader: warning: missing template:
autoheader: Use AC_DEFINE([], [], [Description])

autoheader failed

I don't know autotools well, so that's were I stopped.

My questions:
1. How to get at least stable version working?
2. How to diagnose the problem better? I was thinking of checking out 
revisions as long as I'll found revision that introduced the bug, but as 
you can see I cannot even get stable version working...

Thanks for help.

Tomasz Melcer

More information about the gstreamer-devel mailing list