[gst-devel] Cannot compile latest stable ???good??? plugins.

cascardo at holoscopio.com cascardo at holoscopio.com
Thu Aug 3 15:09:41 CEST 2006

On Thu, Aug 03, 2006 at 02:48:35PM +0200, Tomasz Melcer wrote:
> Hello!
> and from the stderr:
> ERROR (0x82d8118 - 0:00:04.243285000)        audioresample( 5620) 
> resample_ref.c(118):resample_scale_ref: buffer_queue_pull returned NULL

It seems gst-plugins-base 0.10.9 has solved some audioresample bug
related to you problem.

> I tried to diagnose the problem. Due to that the problem exists using 
> three different players, I assumed that there's something wrong with 
> gstreamer. Firstly, I wanted to check if I'll get the same with 
> gstreamer from CVS (yesterday). I managed to compile modules: 
> ???gstreamer???, ???gst-plugins-base???, ???gst-plugins-good??? and ???gst-python??? 
> (for quodlibet). I deinstalled gstreamer debs, then installed the cvs 
> version with prefix /usr, so that ubuntu versions of players will be 
> able to use them without relinking. But seems that I did something 
> wrong, because despite that `gst-inspect` listed many different modules 
> and features, none of them were discovered by quodlibet (which lists 
> available formats at the start), no player could also play anything. 
> Quod libet devs said I should try last stable versions, because it might 
> be that CVS sources are broken at the moment.

Perhaps, that's because you didn't have the necessary external libraries
to build elements supporting any of the formats you wanted to play.
Would you be able to play a wav file?

> So I downloaded from CVS sources tagged with RELEASE-0_10_9 (gstreamer, 
> gst-plugins-base), RELEASE-0_10_3 (gst-plugins-good) and RELEASE-0_10_5 
> (gst-python). gstreamer and base plugins didn't make trouble, but I 
> cannot get through autogen.sh in ???good??? plugins:
> tomasz:~/Projekty/gstreamer/gst-plugins-good% ./autogen.sh 
> + check for build tools
>    checking for autoconf >= 2.52 ... found 2.59, ok.
>    checking for automake >= 1.6 ... found 1.7.9, ok.
>    checking for autopoint >= 0.11.5 ... found 0.14.5, ok.
>    checking for libtoolize >= 1.5.0 ... found 1.5.22, ok.
>    checking for pkg-config >= 0.8.0 ... found 0.20, ok.
> + checking for autogen.sh options
>    This autogen script will automatically run ./configure as:
>    ./configure --enable-maintainer-mode --enable-gtk-doc
>    To pass any additional options, please specify them on the ./autogen.sh
>    command line.
> patching file po/Makefile.in.in
> + running autopoint --force ...
> Copying file mkinstalldirs
> patching file po/Makefile.in.in
> + running aclocal -I m4 -I common/m4 ...
> + running libtoolize --copy --force...
> + running autoheader ...
> autoheader: warning: missing template:
> autoheader: Use AC_DEFINE([], [], [Description])
> autoheader failed
> tomasz:~/Projekty/gstreamer/gst-plugins-good% 

Don't know whether this means a macro AC_DEFINE is missing in
configure.ac or there is no AC_DEFINE macro defined in the m4 files
installed on your system. In this latter case, try to install your
system's package for some files in /usr/share/aclocal or

> I don't know autotools well, so that's were I stopped.
> My questions:
> 1. How to get at least stable version working?
> 2. How to diagnose the problem better? I was thinking of checking out 
> revisions as long as I'll found revision that introduced the bug, but as 
> you can see I cannot even get stable version working...
> Thanks for help.
> Tomasz Melcer

Try the sources in http://gstreamer.freedesktop.org/src/, where you can
find the latest stable versions already "packaged", without needing the
autotools, but only to run configure.

Thadeu Cascardo.

More information about the gstreamer-devel mailing list