[gst-devel] Cross-compile for ARM from Ubuntu?

Joni Valtanen jvaltane at movial.fi
Fri Nov 3 08:48:57 CET 2006

You should try scratchbox to do this. It is quite good cross-compiling 
system and you can build whole system with it.

I have used scratchbox to cross-compile stuff to gp2x.

- Joni

On Thu, 2 Nov 2006, Edward Averill wrote:

> I did a search of the mailing list archives and didn't see anything that
> immediately popped out at me.. so..
> I'm trying to cross-compile for an ARM Linux system from Ubuntu.  I have no
> problems cross-compiling liboil (whew!) but using configure, I've been
> unable to convince gstreamer to NOT use gcc!  I've set $CC to the ARM
> compiler, tried using the CC= in the configure command line, all to no
> avail.. in the output from configure I see:
> checking whether to enable maintainer-specific portions of Makefiles... no
> checking build system type... i686-pc-linux-gnu
> checking host system type... arm-unknown-linux-gnu
> checking for style of include used by make... GNU
> checking for arm-linux-gcc... arm-wrs-linux-gnueabi-armv5tel-glibc_small-gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... yes
> ..so it looks like it's finding my ARM compiler, but when it compiles I see
> the infamous "mode=compile gcc" instead of what the liboil compile shows,
> which is "mode=compile arm-wrs-linux-gnueabi-armv5tel-glibc_small-gcc".  For
> example, the liboil cross-compile shows the following kind of message for a
> compile:
> if /bin/sh ../../libtool --tag=CC --mode=compile
> arm-wrs-linux-gnueabi-armv5tel-glibc_small-gcc -DHAVE_CONFIG_H -I. -I.
> -I../..    -Wall -D_BSD_SOURCE -D_GNU_SOURCE -I../.. -g -O2 -MT
> lib_c_la-ag_clamp.lo -MD -MP -MF ".deps/lib_c_la-ag_clamp.Tpo" -c -o
> lib_c_la-ag_clamp.lo `test -f 'ag_clamp.c' || echo './'`ag_clamp.c; \
> then mv -f ".deps/lib_c_la-ag_clamp.Tpo" ".deps/lib_c_la-ag_clamp.Plo"; else
> rm -f ".deps/lib_c_la-ag_clamp.Tpo"; exit 1; fi
> ..but the gStreamer cross-compile shows..
> if /bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.
> -I../..    -I../../libs -I../.. -I../.. -pthread -I/usr/include/glib-2.0
> -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -Wall -g
> -DGST_DISABLE_DEPRECATED -g -O2 -MT libgstparse_la-lex._gst_parse_yy.lo -MD
> -MP -MF ".deps/libgstparse_la-lex._gst_parse_yy.Tpo" -c -o
> libgstparse_la-lex._gst_parse_yy.lo `test -f 'lex._gst_parse_yy.c' || echo
> './'`lex._gst_parse_yy.c; \
> then mv -f ".deps/libgstparse_la-lex._gst_parse_yy.Tpo"
> ".deps/libgstparse_la-lex._gst_parse_yy.Plo"; else rm -f
> ".deps/libgstparse_la-lex._gst_parse_yy.Tpo"; exit 1; fi
> I even tried copying the installer.sh from liboil to gstreamer and
> rebuilding everything, same results.
> I've looked at a lot of pages on cross-compilation, tried every trick I've
> found, but still no joy.
> Can anyone direct me to some good resources on this topic?  and apologies if
> this is a newbie question... I'm sure it's a "loose nut behind keyboard"
> error..
> All assistance appreciated.
> ..ed..

More information about the gstreamer-devel mailing list