[gst-devel] Cross-compile for ARM from Ubuntu?

Snaik snaik32 at gmail.com
Fri Nov 3 10:48:03 CET 2006

hi edward,
 i have cross-compiled gstreamer including glib, libxml and the required for
arm. BTW. i use fedora core (but that shud not matter.)

export the path to the cross-compilers bin dir to the path environment


next what i do is, export a path for pkgconfig files.
assuming im going to store all the compiled stuff to /opt/gstreamer i would

export PKG_CONFIG_PATH=/opt/gstreamer/lib/pkgconfig

and then the configure command for gstreamer would be
./configure --prefix=/opt/gstreamer --host=arm-linux

[and of course whatever other flags u wanna specify.]
NOTE: gstreamer depends on glib and libxml, so they too need to be cross
compiled , unless u dont want libxml.

so i would recommend that u export the PATH and PKG_CONFIG_PATH variables at
the start of ur entire compilation procedure.
starting from glib onwards...
another thing u might have to do is give symbolic links to cross compiler
i.e. ur toolchains gcc command might look like this

so make a symbolic link to it like arm-linux-gcc

do this for all the commands in ur tool chains bin dir with the
arm-wrs-linux-gnueabi-armv5tel-glibc_small- (ur toolchain prefix) prefix

see if this info helps you
take care

On 11/3/06, Edward Averill <edaverill at hotmail.com> wrote:
> I did a search of the mailing list archives and didn't see anything that
> immediately popped out at me.. so..
> I'm trying to cross-compile for an ARM Linux system from Ubuntu.  I have
> no
> problems cross-compiling liboil (whew!) but using configure, I've been
> unable to convince gstreamer to NOT use gcc!  I've set $CC to the ARM
> compiler, tried using the CC= in the configure command line, all to no
> avail.. in the output from configure I see:
> checking whether to enable maintainer-specific portions of Makefiles... no
> checking build system type... i686-pc-linux-gnu
> checking host system type... arm-unknown-linux-gnu
> checking for style of include used by make... GNU
> checking for arm-linux-gcc...
> arm-wrs-linux-gnueabi-armv5tel-glibc_small-gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... yes
> ..so it looks like it's finding my ARM compiler, but when it compiles I
> see
> the infamous "mode=compile gcc" instead of what the liboil compile shows,
> which is "mode=compile
> arm-wrs-linux-gnueabi-armv5tel-glibc_small-gcc".  For
> example, the liboil cross-compile shows the following kind of message for
> a
> compile:
> if /bin/sh ../../libtool --tag=CC --mode=compile
> arm-wrs-linux-gnueabi-armv5tel-glibc_small-gcc -DHAVE_CONFIG_H -I. -I.
> -I../..    -Wall -D_BSD_SOURCE -D_GNU_SOURCE -I../.. -g -O2 -MT
> lib_c_la-ag_clamp.lo -MD -MP -MF ".deps/lib_c_la-ag_clamp.Tpo" -c -o
> lib_c_la-ag_clamp.lo `test -f 'ag_clamp.c' || echo './'`ag_clamp.c; \
> then mv -f ".deps/lib_c_la-ag_clamp.Tpo" ".deps/lib_c_la-ag_clamp.Plo";
> else
> rm -f ".deps/lib_c_la-ag_clamp.Tpo"; exit 1; fi
> ..but the gStreamer cross-compile shows..
> if /bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I.
> -I../..    -I../../libs -I../.. -I../.. -pthread -I/usr/include/glib-2.0
> -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -Wall -g
> -DGST_DISABLE_DEPRECATED -g -O2 -MT libgstparse_la-lex._gst_parse_yy.lo
> -MD
> -MP -MF ".deps/libgstparse_la-lex._gst_parse_yy.Tpo" -c -o
> libgstparse_la-lex._gst_parse_yy.lo `test -f 'lex._gst_parse_yy.c' || echo
> './'`lex._gst_parse_yy.c; \
> then mv -f ".deps/libgstparse_la-lex._gst_parse_yy.Tpo"
> ".deps/libgstparse_la-lex._gst_parse_yy.Plo"; else rm -f
> ".deps/libgstparse_la-lex._gst_parse_yy.Tpo"; exit 1; fi
> I even tried copying the installer.sh from liboil to gstreamer and
> rebuilding everything, same results.
> I've looked at a lot of pages on cross-compilation, tried every trick I've
> found, but still no joy.
> Can anyone direct me to some good resources on this topic?  and apologies
> if
> this is a newbie question... I'm sure it's a "loose nut behind keyboard"
> error..
> All assistance appreciated.
> ..ed..
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20061103/e9d26f98/attachment.htm>

More information about the gstreamer-devel mailing list