[gst-devel] Bumping the GLib requirement to GLib-2.12?

Stefan Kost ensonic at hora-obscura.de
Sat Dec 15 11:26:58 CET 2007


Tim Müller schrieb:
> Hi,
> currently GStreamer requires only GLib 2.8, which was released in
> mid-2005.
> I think it would be nice if we could bump our GLib requirement to
> something slightly more current so we can make use of all the new APIs
> that were added in the last two years.
> My suggestion is to bump the requirement to GLib 2.12, which was
> released in mid-2006.
> This requirement would be met by ubuntu edgy/feisty/gutsy, debian
> stable/testing/sid and Fedora Core 6 upwards, and seems to me like a
> good compromise between bleeding edge and completely outdated.
Sounds like a good plan!
OpenSuse-10.2 has glib2-2.12.4.

Btw. if you checkout gtk-doic from svn ther eis a nice now tool from matthias
hasselman (tbf).

cd gstreamer
for file in gst/*.c; do gtkdoc-depscan -v --book glib:2.8.0 $file; done

Its not perfect yet (needs a blacklist), but looks useful to me.


> What do people think? Any objections?
>  Cheers
>   -Tim
> -------------------------------------------------------------------------
> SF.Net email is sponsored by:
> Check out the new SourceForge.net Marketplace.
> It's the best place to buy or sell services
> for just about anything Open Source.
> http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel

More information about the gstreamer-devel mailing list