[gst-devel] Problem with live source in bin

Dennis Ranke mail at exoticorn.de
Tue Feb 5 00:21:29 CET 2008


While refactoring a small application I am writing, I tried to move 
parts of my pipeline to a bin. However, the pipeline never seems to 
really start playing when there is a live source as well as sinks that 
need preroll in the bin.

I have stripped my pipeline down to this very simple case:

gst-launch videotestsrc ! \( ximagesink audiotestsrc is-live=true ! 
fakesink \)

Without the 'is-live=true' or without the braces (ie. without a bin) it 
works fine.
Is there some reason for this not working I am missing here?

I tried to look through the logs produced by --gst-debug-level=4 but 
only got as far as: The sinks never send a ASYNC_DONE message (before 
the window is closed), and the audiotestsrc is never activated (no 
"<audiotestsrc0> Activating in push mode").
That's it though, i have no idea what the real cause for this is and how 
I can prevent it.

The odd thing is that, as far as I can see, cheese is doing more or less 
the same thing when recording video - and it's working there.

This is with gstreamer 0.10.14 on ubuntu gutsy.


More information about the gstreamer-devel mailing list