[gst-devel] creating matroska from h264 problem

tyggrysio tyggrysio at gazeta.pl
Tue Mar 4 11:37:24 CET 2008

 I have tried to create matroska movie from h264 video, but output file size
was always 5kB - regardless of input file. I have used following
gst-launch-0.10.exe filesrc location=movie.h264 !
"video/x-h264,height=480,width=640,framerate=25/1" ! matroskamux ! filesink

I have also tried to decode my h264 video and create matroska from received
raw video:
gst-launch-0.10.exe filesrc location=movie.h264 !
"video/x-h264,height=480,width=640,framerate=25/1" ! ffdec_h264 !
matroskamux ! filesink location="E:\output.mkv"
I have receiced output file, but I can't play it in mplayer, because (this
is part of my mplayer log):
==> Found video stream: 0
ds_fill_buffer: EOF reached (stream: video)
LAVF_check: Matroska file format
libavformat file format detected.
[matroska @ 00B5D3B4]Read error at pos. 13 (0xd)
LAVF_header: av_open_input_stream() failed
demux_aac_probe, failed to detect an AAC stream
WINSOCK2 uninit
Exiting... (End of file)

I don't know why I have this "error at pos. 13". I suppose that something is
wrong with my command, but I can't find what. I've search through this list
archive, but I didn't find anything helpful.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20080304/f049fd40/attachment.htm>

More information about the gstreamer-devel mailing list