[gst-devel] problems compiling ffmpeg-gstreamer plugin for ARM

John Faith jfaith at freescale.com
Thu Mar 13 01:15:11 CET 2008

Hi Norbert,
I've built gst-ffmpeg 0.10.3 for the i.MX31ADS using the ltib tool 
(http://www.bitshrine.org).  The build did something like this:

./configure --prefix=/usr --host=arm-linux --build=i686-pc-linux-gnu 
--without-check --disable-altivec
make install DESTDIR=/path/to/rootfs
find /path/to/rootfs/usr/lib/ -name '*.la' | xargs rm -f

The target files created in my environment were:

Did you save the output when you did 'make install' to see where files 
were put?


Norbert Leder wrote:
> Hi,
> first of all I hope that belongs here, sorry if not.
> I am a student on TU-Wien and I've got a problem with my current project.
> Today I tried to build and install the ffmpeg-gstreamer plugins for the 
> iMx31 Freescale
> board we are using for our current project.
> I tried to build the sourcepackage using ./configure --host=arm and the
> /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc
> compiler.
> It compiled/installed without an error but it didn't create me .so 
> files automatically
> and I wasn't able to make it work on the iMx31.
> I am really lost! Please give me some advice!
> with best regards
> Norbert LEDER

More information about the gstreamer-devel mailing list