[gst-devel] VC-1 support on Windows and other platforms

Andreas Schuler andreas at neokast.com
Fri Mar 28 22:42:31 CET 2008

Hi all,

I am currently evaluating GStreamer for a project I am working on. The bulk
of the content I am dealing with is encoded in VC-1 (WMA for audio). I have
spent quite a bit of time getting more familiar with the GStreamer concepts
but I have not been able to play back a WMV file (with VC-1 encoded video)

I have tried using the playbin, playbin2, as well as a custom built pipeline
(using the decodebin). I also tried with the ASF demuxer so I could inspect
the video caps at its output. There I was able to confirm that the fourcc is
correctly identified as WMVC1.

Despite a number of attempts I have not been able to get my WMV file to show
any video (audio is working fine). I have tried other files (xvid encoded),
which are working fine.

I assumed that this should work since ffmpeg has been supporting VC-1
decoding for some time now.

I am using the following versions (mainly because those are the most recent
Windows binaries available):

GStreamer: 0.10.17
gst-plugins-base: 0.10.17
gst-plugins-good: 0.10.7
gst-plugins-bad: 0.10.6
gst-plugins-ugly: 0.10.7
gst-ffmpeg: 0.10.2

Can anyone tell me whether VC-1 is currently supported by GStreamer (on
Windows and other platforms), or whether there must be a problem with my
setup somehow? Also, if VC-1 currently isn't supported, are there any plans
to include that in the near future? And, will VC-1 encoding also available
at some point?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20080328/26da1206/attachment.htm>

More information about the gstreamer-devel mailing list