[gst-devel] Need help getting simple rtp pipeline to work

Jon Dufresne jon.dufresne at gmail.com
Wed May 21 01:04:22 CEST 2008

I am trying to experiment with gstreamer. I am particularly interested
in the rtp elements. I have tried to read quite a bit to get idea of
how to develop  and usewith gstreamer. So far I have mostly messed
around with the python bindings, gst-inspect, and gst-launch. Even
though I have only just started using this I can already see how
powerful a system with gstreamer's design can be.

I have been trying to set up a simple pipeline using rtp and simply
can not get it to work. I have been working on this for three days now
with no progress. I am running the following two pipelines in two
different terminals. I start the receiving pipeline first

receiving pipeline:
gst-launch -v udpsrc ! .recv_rtp_sink_0 gstrtpbin ! rtptheoradepay !
theoradec ! autovideosink

sending pipeline:
gst-launch -v videotestsrc ! theoraenc ! rtptheorapay !
.send_rtp_sink_0 gstrtpbin ! udpsink

Whenever I run this I receive the following error in the terminal
running the receiving pipeline:

ERROR: from element /pipeline0/udpsrc0: Internal data flow error.
Additional debug info:
gstbasesrc.c(2099): gst_base_src_loop (): /pipeline0/udpsrc0:
streaming task paused, reason not-negotiated (-4)

I'm not sure exactly what this means I have searched for what this
might mean, but I haven't been able to find any solutoins.

Any help as to what I am doing wrong?


More information about the gstreamer-devel mailing list