[gst-devel] Problem using gnomevfs plugin and ssh

Tiago Katcipis katcipis at inf.ufsc.br
Tue Feb 2 22:54:36 CET 2010

i updated my gnomevfs to version 2.24.2 (it was 2.24.0) and gstreamer /
gstreamer base to (it was 0.10.25) and it get no more glib
error*failed to allocate
*, and the application no longer crashes, but all the warnings on
gnome-vfs-modules are still there. Don't know if the bug is really

On Mon, Feb 1, 2010 at 12:28 PM, Tiago Katcipis <katcipis at inf.ufsc.br>wrote:

> Can anyone at least help me to determine if it is a bug or something wrong
> i am doing? I'm thinking on reporting it as a bug on gstreamer bugzilla.
> best regards,
> Katcipis
> On Wed, Jan 27, 2010 at 10:08 PM, Tiago Katcipis <katcipis at inf.ufsc.br>wrote:
>> I'm developing an application that does heavy use on the gnomevfssrc
>> plugin to load urls from different protocols, most of the urls are ssh.
>> Everything was going fine since we started to notice an odd behaviour on our
>> tests, when the application receives the request to open the same ssh url
>> multiple times it gives a lot of warnings, and sometimes it even crash.
>> Because of that odd behaviour i made a simple application reproducing this
>> problem, basically you pass a url and how many pipes reading that url at the
>> same time you want, it is just a gnomevfssrc ! fakesink pipe (on more
>> complex pipelines the error is the same). With this code test if you open
>> even a hundred times the same http address it works fine, but if you open 3
>> or more times the same ssh url, it gets this error (it is the same error i
>> get on the real application, sometimes the errors are bigger but it is the
>> same warnings multiple times before the crash):
>> *(gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Message length too
>> long: 1761607680
>> (gnomevfs_ssh:5316): gnome-vfs-modules-WARNING **: ID mismatch (15 != 5)
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Message length too
>> long: 1728053248
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Message length too
>> long: 100663312
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Could not read 1 bytes
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Could not read 4 bytes
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: ID mismatch
>> (4286513152 != 8)
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Expected
>> SSH2_FXP_HANDLE(102) packet, got 0
>> (gnomevfs_ssh:5316): gnome-vfs-modules-CRITICAL **: Could not read 4 bytes
>> GLib-ERROR **: /build/buildd/glib2.0-2.22.3/glib/gmem.c:136: failed to
>> allocate 18446744073701097472 bytes
>> aborting...
>> Aborted*
>> I don't know if it is something that i am doing wrong, but i suppose i am
>> allowed to open the same url multiple times to do different processing on
>> that url, so it sens like a bug on gnomevfssrc, the fact that file and http
>> protocols works fine is an indicative that the problem is related to
>> gnomevfssrc and ssh (i didn't tested with others protocols like smb or ftp,
>> but the test code can test any of these).
>> Of course when the test is run with only one pipeline reading the ssh url
>> it works just fine, no warnings or errors are given, 2 or more makes things
>> go ugly.
>> can someone help me to see what i am doing wrong or if it is really a bug?
>> The tests have been made on Ubuntu 9.10 32 bits and 64 bits with gstreamer
>> 0.10.25 (same error on both).
>> the source code of the test can be found on:
>> https://svn.inf.ufsc.br/katcipis/c/gstreamer/gnomevfs_ssh_bug/
>> best regards,
>> Katcipis
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20100202/7fc80091/attachment.htm>

More information about the gstreamer-devel mailing list