Still can't get videomixer to do live video at full frame rate

wally_bkg wb666greene at
Wed Aug 17 08:13:47 PDT 2011

Tim-Philipp Müller-2 wrote:
> On Wed, 2011-08-17 at 06:48 -0700, wally_bkg wrote:
>> Videomixer2 was the first thing I tried, doesn't exist in the Ubuntu
>> 10.04
>> system: (...)
>> I thought the documentation blurb said videomixer2 will replace
>> videomixer,
>> I'd assumed that had happened by now.
> It has. Maybe you need to upgrade to a newer Ubuntu or try the GStreamer
> PPA for newer GStreamer packages. 10.04 is more than a year old..
> Cheers
>  -Tim

I tried the 10.04 PPA a few months ago and it hosed my system to the point

gst-launch v4l2src ! xvimagesink 

wouldn't even work.  All other multimedia stuff was pretty much foobar too.

Recovering was a PITA I'm not desperate enough to try again at present.

Changing the sync property on the xvimagesink to false may be the solution
as this pipeline:

gst-launch v4l2src device=/dev/video0 ! video/x-raw-yuv,format
=\(fourcc\)I420, framerate=\(fraction\)30000/1001, width=640, height=480 !
timeoverlay ! videomixer name=mix sink_0::alpha=1.0 sink_0::xpos=0
sink_0::ypos=0 sink_1::alpha=1.0 sink_1::xpos=0 sink_1::ypos=480 
sink_2::zorder=3 ! xvimagesink sync=false v4l2src device=/dev/video1 !
video/x-raw-yuv,format=\(fourcc\)I420, framerate=\(fraction\)30000/1001,
width=640, height=480 ! timeoverlay ! mix. videotestsrc pattern=2 !
video/x-raw-yuv,format=\(fourcc\)I420, framerate=\(fraction\)1/1, width=640,
height=960 ! mix.

Has maintained full speed for a stream for well over an hour, which is
almost always a long enough epoch, although the Xorg CPU usage has increased
to ~25%.  It has also survived the video glitches of ff/rev of the tape and
the transitions of where the recording was started and stopped originally.

I'm having some trouble with the C syntax to get the videomixer sink pads
and set the ypos properties on them as done by the gst-launch.  Any examples
out there?

The real test will be when I get it to terminate in my appsink instead of
xvimagesink so I can delta the stacked buffer timestamps to verify full
frame rate is actually achieved.

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list