Encoder (x264enc) and Decoder VDPAU incompatibility?

Jérémy Lauraire jeremy.lauraire at gmail.com
Fri Aug 26 06:50:16 PDT 2011

Thanks Julien...

Best idea ever! I have tried your pipeline :

gst-launch-0.10 videotestsrc ! x264enc ! queue !  vdpauh264dec !
vdpauvideopostprocess ! vdpausink

which doesn't work for unknow reason for me... But I have tried to go a
little bit further and I did a SERVER :

*> gst-launch-0.10 filesrc location=/home/jeremy/Bureau/BBB.mkv !
matroskademux ! decodebin ! queue ! x264enc ! queue ! udpsink
host= port=10308

.... and a CLIENT :

*> GST_DEBUG="*:9" gst-launch-0.10 udpsrc port=10308 ! video/x-h264 !
vdpauh264dec ! vdpauvideopostprocess ! vdpausink*
And I have reproduce exactly the same behavior as I obtained :

gstbasevideodecoder.c:567:gst_base_video_decoder_drain: no sync, scanning
0:00:14.391205975 27686      0x1e5a190 DEBUG       basevideodecoder
gstbasevideodecoder.c:587:gst_base_video_decoder_drain: found possible sync
after 0 bytes (of 3)
0:00:14.391212857 27686      0x1e5a190 DEBUG           vdpauh264dec

What can I do to correct this....? I will work on those pipeline to fix that
before I get back to my code. Thanks a lot!!!

PS : are you from France cause I know a Julien Moutte there.... no such

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20110826/ebf193cb/attachment.htm>

More information about the gstreamer-devel mailing list