audiofx plugins work with gst-launch but not from code

Sean McNamara smcnam at
Tue Aug 30 19:51:32 PDT 2011


On Tue, Aug 30, 2011 at 7:32 PM, cleojones <cleo_jones7 at> wrote:
> Working on my first program using gstreamer, on Maemo (nokia N900), and have
> the following problem:
> I can do this:
> gst-launch-0.10 autoaudiosrc ! audioconvert ! audioamplify amplification=2 !
> lame quality=9 ! shout2send ip=myip password=mypass mount=/mount port=myport
> But I the same pipeline, constructed in C, streams total silence from my
> program. I've tried created pipeline in C using gst_parse_launch as well as
> by creating each element manually, with the same problem. If I omit the
> audioamplify element, works fine (streams microphone input). As soon as I
> try to add audioamplify, silence (no matter what I set amplification to).

Have you tried getting the property back from the audioamplify element
to make sure that it's set correctly?

I was going to say make sure you link all your elements together, but
since you said you used gst_parse, I don't think that could be an
issue. My guess (without seeing your code) is that the audioamplify
element is getting its amplification property set to 0, which would
probably be equivalent to silencing the stream (though I'm not sure
because I'm not very familiar with that element; I normally use

Without having your actual code (or a trivial test program that
exhibits the same behavior), it's impossible to tell what is wrong.


> Eventually I want to run this through the audiocheblimit element as well
> (which works fine with gst-launch) but it also seems to have a problem when
> created from my own code.
> Any help much appreciated!
> --
> View this message in context:
> Sent from the GStreamer-devel mailing list archive at
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at

More information about the gstreamer-devel mailing list