Issue in vorbisdec

W.A. Garrett Weaver weaverg at
Sat Mar 24 07:14:50 PDT 2012

Thank you for getting back to me. What I was trying to do was run this
audio UDP transmission script using the vorbis codec:

gst-launch-0.10 pulsesrc
device=alsa_input.usb-046d_0809_B11D4DC2-02-U0x46d0x809.analog-mono !
audioconvert ! vorbisenc ! rtpvorbispay ! udpsink host= port=3000

This worked fine. The receiver script did not.

gst-launch-0.10 udpsrc multicast-group= auto-multicast=true
port=3000 caps=application/x-rtp ! gstrtpjitterbuffer drop-on-latency=false
latency=100 ! rtpvorbisdepay ! vorbisdec ! pulsesink

Which reported that it "Could not decode stream" and "Could not switch code

I found, from other resources, that adding '-v' to the transmission script
would reveal the correct, but lengthy, caps output but plugging that
directly into the receive script did not work saying that erroneous
pipeline: could not set property "caps" in element "udpsrc0".

However, putting it between single quotes, which is something that I didn't
think to do: worked. Thank you.

On Sat, Mar 24, 2012 at 5:01 AM, Tim-Philipp Müller <t.i.m at> wrote:

> On Sat, 2012-03-24 at 03:46 -0700, garrett wrote:
> > Hello, I have come across the same issue as the OP of this message. I'm
> > giving it a bump in the hopes that the problem can be resolved.
> >
> > After doing some research: I found that running the server script in
> verbose
> > mode '-v' would return the caps value that you would need to copy and
> paste
> > into udpsrc. Unfortunately: this proved unsuccessful, it returned Syntax
> > error: "(" unexpected and when the string is enclosed in quotes, it
> returns
> > erroneous pipeline: could not set property "caps" in element "udpsrc0"
> >
> > Is there something additional that must be done to the string to make the
> > receiving script function beyond surrounding it in quotes?
> Could you post the exact command line that caused these problems? You
> can also try single quotes 'foo' vs. normal quotes ("foo"), or escape
> brackets like \(buffer\)1234
> Cheers
>  -Tim
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at

*W.A. Garrett Weaver *
weaverg at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list