RTSP server using v4l2src

yusuf.husainy yusuf.husainy at gmail.com
Wed Apr 10 07:18:18 PDT 2013


Thanks Gary and Robert for the quick reply.

Interestingly, if i specify a format in the caps filter string of my server
pipeline(along with the framerate and resolution), i am unable to connect at
all(using both videotestsrc as well as v4l2src). 

However, the earlier experiment by me using videotestsrc worked(even without
specifying the format caps of the src.).

Now, i deleted the test-video.c file, copied again from source and then
recompiled it again. I ran the server and it worked, with both videotestsrc
and v4l2src!!!!!

Speaking about the caps negotiation, i saw the gst-inspect of both the
sources, and the x264enc and ffenc_mpeg4. they match, i mean, the source are
capable of producing I420 format and the encoders can take this kind of
 But strangely, it seems, if i specify this explicitly, i t wont work(as
said before).

I had even tried the ffmpegcolorspace element as Gary had suggested, but to
no result.

Then, now, even without the ffmpegcolorspace element, it works just fine,
meaning, i can see the lice stream of the webcam on the client using VLC and
movie player(I am running a ubuntu 12.04).

However, I have encountered another problem. 

Although the live feed streams perfectly well, but with a 4 second delay.

I don't know, maybe this is a problem with the client side (VLC,etc). Or it
maybe due to some delay introduced by v4l2src(however, this is doubtful as i
had streamed over a normal udp link from server to client using pure udpsink
and udpsource elements, there was no problem.).

I would appreciate any suggestions or advice.

Yusuf Husainy.

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/RTSP-server-using-v4l2src-tp4659459p4659464.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list