RTSP server using v4l2src

yusuf.husainy yusuf.husainy at gmail.com
Fri Apr 12 04:40:28 PDT 2013

Hello again,

Finally, I have solved the problem,

The delay of 4sec was caused due to the x264enc element, which I was using
in the server pipeline.

I replaced it with ffenc_mpeg4, i.e MPEG4-part2 video codec(h264 is
MPEG4-part10 video codec). I see no(zero) delay at all if I run a gst-launch
pipeline on the client side using rtspsrc. 

However, if I stream live on VLC at the client, I do observe a 1-1.5 sec

The strange part is, it works with VLC (both videotestsrc and v4l2src) if i
open VLC at command line as:
$vlc rtsp://

But if I open the VLC application using dash(ubuntu 12.04), and then select
stream option, after entering the rtsp:// url, it says failed to connect )

Now i want to record this live stream using VLC(in the case where I opened
VLC using command line).

After saving it, if I playback the recorded file using VLC, it does not
play!!!(although VLC was streaming the same file perfectly just a while

I think VLC does support MPEG4-part2  video codec(as per wikipedia). So why
isin't VLC playing the .mp4 container file during playback????

The server pipeline:
vfl2src device=/dev/video0 ! ffenc_mpeg4 ! rtpmp4vpay name=pay0 pt=96

The client pipeline:
1. VLC media player (streaming using command line).(wasn't able to save as
VLC said failed to open URL...although it was streaming it).
2. gst-launch -v rtspsrc ! rtpmp4vdepay ! ffdec_mpeg4 ! xvimagesink (in this
case I observed 0 sec delay during streaming).
3. gst-launch -v rtspsrc ! rtpmp4vdepay ! ffdec_mpeg4 ! ffmpegcolorspace !
ffenc_mpeg4 ! filesink ! location=Desktop/testing5.mp4 (in this case VLC
failed to playback the .mp4 file).
4. gst-launch -v rtspsrc ! rtpmp4vdepay ! ffdec_mpeg4 ! ffmpegcolorspace !
ffenc_mpeg4 ! mp4mux(I thought this would help) ! filesink !
location=Desktop/testing5.mp4 (in this case also VLC failed to playback the
.mp4 file).

I just want to stream it live, record it as well as playback it using VLC,
or any other media player.

Any help is really appreciated!!!!!

Yusuf Husainy.

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/RTSP-server-using-v4l2src-tp4659459p4659483.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list