RTSP server problems with uvch264src H/W+ encoded H.264 output

yusuf.husainy yusuf.husainy at gmail.com
Thu Apr 25 01:36:46 PDT 2013

Hi Robert,

I had also seen the same error, Not enough data to read marker content. 

I did as you suggested, I commented the error line and built gst-plugins-bad

Then, I ran this pipeline with GST_DEBUG=uvch264src:5
 gst-launch-1.0 -v uvch264src device=/dev/video0 name=src auto-start=true
src.vidsrc ! queue ! video/x-h264,width=1920,height=1080,framerate=30/1 !
h264parse ! matroskamux ! filesink
location=/home/ajay/Desktop/testinguvch264HDC920.mkv src.vfsrc ! queue !
video/x-raw,width=432,height=240,framerate=30/1 ! xvimagesink
This is the log for above pipeline http://pastebin.com/2piRQrEt

With respect to the above pipeline and debug log:
There is still some problem with uvch264src, as after the same amount of
time-34.66 secs, the data flow gets corrupted.
Although, now, the pipeline does not end, but if you view the stream on
xvimagesink, then after 34.66 secs, the video blurs out and gets corrupted.
Also another point I want you to look at is in the above log, at around 
0.32 secs, the WARN messages from:
0:00:00.325403379 27386  0x8e8c180 WARN              uvch264src
gstuvch264_src.c:1861:xu_query:<src> PROBE GET_LEN error
0:00:00.325438230 27386  0x8e8c180 WARN              uvch264src
gstuvch264_src.c:985:set_ltr:<src>  LTR_BUFFER_SIZE GET_CUR error
0:00:00.325467493 27386  0x8e8c180 WARN              uvch264src
gstuvch264_src.c:1861:xu_query:<src> PROBE GET_LEN error
0:00:00.325494522 27386  0x8e8c180 WARN              uvch264src
gstuvch264_src.c:1143:update_ltr:<src>  LTR_BUFFER_SIZE GET_CUR error

What I make out is, after 34 secs, uvch264src fails to produce the data
buffers or it fails to send them upstream.

Now, I get this error: Expected 0 auxillary data, got 10720 bytes. This
error is in the same file: uvch264_mjpegdemux.c as:

      if (segment_size > aux_size) {
            ("Expected %d auxiliary data, got %d bytes", aux_size,
                segment_size), (NULL));
        ret = GST_FLOW_ERROR;
        goto done;

Also a few question:
1. What is your video source: C920 or some other camera?
2. What is your data flow that you see indefinitely-can you see later than
say 35 secs or so. Give it a running test of atleast 2-3 mins and check if
some strange behaviour occurs.
3. Before you hacked out those error line, were you also seeing the data
flow till 34 - 35 secs only?

This is definitely a  bug in either the uvch264src or v4l2src or maybe my
camera(I doubt my camera as it plays well in VLC).

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/RTSP-server-problems-with-uvch264src-H-W-encoded-H-264-output-tp4659582p4659671.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list