Release 1.1.2: "gst-inspect-1.0: symbol lookup error"

Adam Goodwin at
Mon Jul 22 08:12:18 PDT 2013

Hi again,

After clarification from Robert Krakora regarding uvch264_src in version
0.10 (thanks for that bit of info), I've decided to stick with the 1.1.2
release for now as I was only missing a couple of dependencies of
uvch264src - which I have now found.

Unfortunately what I'm now finding is that when I configure, make and
install GStreamer 1.1.2, there seems to be something quite wrong. After
installing, running gst-inspect-1.0 gives the following:

gst-inspect-1.0: symbol lookup error: gst-inspect-1.0: undefined symbol:

If I "make uninstall" GStreamer, and run the build of gst-inspect-1.0 from
./tools/gst-inspect-1.0, I get the following:

staticelements:  bin: Generic bin
staticelements:  pipeline: Pipeline object

Total count: 1 plugin, 2 features

This seems much more reasonable, but I'd like to install GStreamer
properly. I've burned a few hours trying to get the install to work, but
I'm having no luck.

I couldn't find the same error mentioned anywhere else, but does anyone
recognise it or know why it would occur?

I can provide the output from ./configure, make, and make install, but it
doesn't look like anything went wrong there. I also tried release 1.0.8
again and it seemed to install fine, but unfortunately uvch264src isn't
ported to that release.

If nobody has any ideas I guess I'll just try cloning the 0.10 repository
and hopefully get uvch264_src that way.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list