AAC parsing in gstreamer 1.0.10

bob-bob bob.wightman at pixsan.com
Wed Apr 2 03:30:56 PDT 2014


I'm new to gstreamer. I'm running OpenSuse 12.3. I am using the following
pipeline to decode a live mux:

./gst-launch-1.0 dvbsrc  bandwidth=8 frequency=522000000 pids=100:101:102  !
tsdemux program-number=4170 name=demux ! queue max-size-buffers=0
max-size-time=0 ! h264parse ! avdec_h264 ! videoconvert ! autovideosink
demux. ! queue max-size-buffers=0 max-size-time=0 ! aacparse !  avdec_aac !
autoaudiosink demux.

If I omit the audio part of the pipeline then I get video but obviously no

If I set GST_DEBUG=3 then I get the following warnings:

0:00:04.351948875  8481       0xd62e80 WARN                 basesrc
gstbasesrc.c:2812:gst_base_src_loop:<dvbsrc0> error: Internal data flow
0:00:04.352000970  8481       0xd62e80 WARN                 basesrc
gstbasesrc.c:2812:gst_base_src_loop:<dvbsrc0> error: streaming task paused,
reason not-negotiated (-4)

I've also tried setting the last part of the pipeline to fakesink and get
the same mode of failure. It appears to be the connection between aacparse
and avdec_aac that's the problem.

I've tried using version 1.2.3 but at the moment cannot get this to play
just the video.

Any clues as to what I'm doing wrong or things to try?

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/AAC-parsing-in-gstreamer-1-0-10-tp4666250.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list