AAC parsing in gstreamer 1.0.10

Tim Müller tim at centricular.com
Wed Apr 2 04:13:42 PDT 2014

On Wed, 2014-04-02 at 03:30 -0700, bob-bob wrote:

Hi Bob,

> I'm new to gstreamer. I'm running OpenSuse 12.3. I am using the following
> pipeline to decode a live mux:
> ./gst-launch-1.0 dvbsrc  bandwidth=8 frequency=522000000 pids=100:101:102  !
> tsdemux program-number=4170 name=demux ! queue max-size-buffers=0
> max-size-time=0 ! h264parse ! avdec_h264 ! videoconvert ! autovideosink
> demux. ! queue max-size-buffers=0 max-size-time=0 ! aacparse !  avdec_aac !
> autoaudiosink demux.
> If I omit the audio part of the pipeline then I get video but obviously no
> audio. 
> gstbasesrc.c:2812:gst_base_src_loop:<dvbsrc0> error: streaming task paused,
> reason not-negotiated (-4)

Some problem with caps negotiation. Could you pass -v to gst-launch-1.0
and show us the output of that with the above pipeline?

> I've also tried setting the last part of the pipeline to fakesink and get
> the same mode of failure. It appears to be the connection between aacparse
> and avdec_aac that's the problem.

Does it work with 'faad' instead of avdec_aac? Does putting
'audioconvert ! audioresample' in front of the autoaudiosink help? Does
it work with aacparse ! fakesink ? (if yes, what are the caps on
fakesink then, see gst-launch-1.0 -v ... output)

> I've tried using version 1.2.3 but at the moment cannot get this to play
> just the video.

Do you have a captured sample of the stream somewhere for us to have a
look at?


Tim Müller, Centricular Ltd - http://www.centricular.com

More information about the gstreamer-devel mailing list