tsdemux & ffec_h264: ffmpeg :0:: non-existing PPS referenced

kayoss12 noureddinetariba at gmail.com
Tue Apr 22 16:20:00 PDT 2014

thank you for you answer ,  to so i try run pepepline client the  first , and
second i run the commande on RPI ,  but still not working , the Camera run
on PI , but i can't receive the stream on my PC client 
there are any fault in the pepeline ??
thanks in advance for  your answer 

 client  :

gst-launch-1.0 udpsrc port=5000 ! "application/x-rtp, media=(string)video, \
clock-rate=(int)90000, encoding-name=(string)MP2T, payload=(int)33,
ssrc=(uint)4251539348, \
 timestamp-offset=(uint)2033210929, seqnum-offset=(uint)34671" !
rtpmp2tdepay \
 ! tsparse ! tsdemux  ! "video/x-h264" ! avdec_h264 ! autovideosink 

 RPI :  

gst-launch-1.0 rpicamsrc bitrate=1000000 !
"video/x-h264,width=640,height=480" !\
queue ! h264parse ! queue ! mux.  alsasrc device=hw:1,0 ! audioconvert ! \
lamemp3enc ! "audio/mpeg"! queue !   mux. mpegtsmux name=mux ! queue ! \
udpsink host= port=5000 -v 

 i  got this warning

Warnig client :
Additional debug info:
gstrtpbasedepayload.c(381): gst_rtp_base_depayload_chain ():
Received invalid RTP payload, dropping
WARNING: from element /GstPipeline:pipeline0/GstRtpMP2TDepay:rtpmp2tdepay0:
d not decode stream.

also i have warning in RPI
WARNING: from element /GstPipeline:pipeline0/GstAlsaSrc:alsasrc0: Can't
record audio fast enough
Additional debug info:
gstaudiobasesrc.c(848): gst_audio_base_src_create ():
Dropped 8820 samples. This is most likely because downstream can't keep up
and is consuming samples too slowly.

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/tsdemux-ffec-h264-ffmpeg-0-non-existing-PPS-referenced-tp4665890p4666552.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list