Link libraries in gstreamer-0.10

Sérgio Agostinho sergio.r.agostinho at
Fri Dec 5 05:05:52 PST 2014

Have you tried messing around with the environmental variable


for more info.


2014-12-05 11:59 GMT+01:00 Mayank Agarwal <mayank77fromindia at>:

> Hi
> I am running make install to generate my plugin .so and .la file in
> /usr/local/lib/gstreamer-1.0 directory
> I want to change the path so that .so and .la files corresponding to
> my plugin will
> generate in gstreamer-0.10 directory which is:e
> /usr/lib/x86_64-linux-gnu/gstreamer-0.10
> now if i am doing gst-launch-1.0 i am getting the name of my plugins
> but gst-launch-0.10 is not showing.
> even simple pipelines described in gstreamer tutorials are showing errors
> in gstreamer-1.0 but running fine in gstrea,er-0.10
> i.e why ii want to register my plugin with gstreamer-0.10
> Any pointers how can i do.i have tried using libtool,LD_LIBRARY_PATH
> but to no help.
> Regards
> Mayank
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list