RTP client doesn't mux a/v streams with RTPBIN

Frogger marcox872002 at libero.it
Wed Feb 5 02:42:03 PST 2014

I'm trying to mux two streams (audio AAC and video H264) to mp4 file using

gst-launch-0.10 -vvv filesrc location=bunny.mp4 ! qtdemux name=dem dem. !
queue ! rtph264pay ! udpsink host= port=12345 dem. ! queue !
rtpmp4gpay ! udpsink host= port=12346

gst-launch-0.10 -vvv gstrtpbin name=rtpbin latency=200 udpsrc port=12345
caps="application/x-rtp, media=(string)video, clock-rate=(int)90000,
payload=(int)96, ssrc=(uint)2893543565, clock-base=(uint)2194033460,
seqnum-base=(uint)7702" ! rtpbin.recv_rtp_sink_0 rtpbin. ! rtph264depay !
h264parse ! queue ! mux. udpsrc port=9001 ! rtpbin.recv_rtcp_sink_0 udpsrc
port=12346 caps="application/x-rtp, media=(string)audio,
clock-rate=(int)22050, encoding-name=(string)MPEG4-GENERIC,
encoding-params=(string)2, streamtype=(string)5, profile-level-id=(string)2,
mode=(string)AAC-hbr, config=(string)1390, sizelength=(string)13,
indexlength=(string)3, indexdeltalength=(string)3, payload=(int)96,
ssrc=(uint)2908762013, clock-base=(uint)699954229, seqnum-base=(uint)40878"
! rtpbin.recv_rtp_sink_1 rtpbin. ! rtpmp4gdepay ! queue ! mux. udpsrc
port=9501 ! rtpbin.recv_rtcp_sink_1 qtmux name=mux ! queue ! filesink
location=test.mp4 sync=false

Server start to stream and finish correctly at the end of file; client
remain stuck as if waiting for something.
I also tried with matroskamux with same result.
Output strings are very long, so if you need them I'll paste here. 

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/RTP-client-doesn-t-mux-a-v-streams-with-RTPBIN-tp4665103.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list