cerbero bootstrap problem

Jeremy Wilson jwilson at redgiant.com
Wed Feb 19 13:24:59 PST 2014

Thanks Sebastian for the quick response.

I had cloned from git://anongit.freedesktop.org/gstreamer-sdk/cerbero as
per the instructions on

So I deleted my cerbero folder, and cloned again from
http://cgit.freedesktop.org/gstreamer/cerbero as per your suggestion
(without specifying the branch, so I got master).

It failed again at the same point, but this time presented a menu of
options for how to proceed.  I selected to rebuild the recipe from scratch,
but the same error occurred.

I then tried again with the 1.2 branch, i.e.

git clone --branch 1.2 http://cgit.freedesktop.org/gstreamer/cerbero

It ran for a lot longer this time, but failed in gettext-tools:

checking whether <wchar.h> uses 'inline' correctly... rm: cannot lstat
`conftest.exe': Permission denied
configure: error: <wchar.h> cannot be used with this compiler
(i686-w64-mingw32-gcc -std=gnu99 -Wall -g -O2 -DWINVER=0x0501 -I/c/Use
This is a known interoperability problem of glibc <= 2.5 with gcc >= 4.3 in
C99 mode. You have four options:
  - Add the flag -fgnu89-inline to CC and reconfigure, or
  - Fix your include files, using parts of
  - Use a gcc version older than 4.3, or
  - Don't use the flags -std=c99 or -std=gnu99.
Configuration aborted.
rm: cannot lstat `conftest.exe': Permission denied
***** Error running 'bootstrap' command:
Recipe 'gettext-tools' failed at the build step 'configure'

The reference to conftest.exe made me nervous that Avast had switched on
again, so I made sure it was disabled again, deleted the cerbero folder and
~/.cerbero/build-tools file, recloned cerbero, and tried again.  Now I'm
back to the original error (which I think occurs a lot earlier then the one

libtool: link: i686-w64-mingw32-gcc -shared  .libs/bindtextdom.o
.libs/dcgettext.o .libs/dgettext.o .libs/gettext.o .libs/finddomain
.o .libs/hash-string.o .libs/loadmsgcat.o .libs/localealias.o
.libs/textdomain.o .libs/l10nflist.o .libs/explodename.o .libs/dcigett
ext.o .libs/dcngettext.o .libs/dngettext.o .libs/ngettext.o .libs/plural.o
.libs/plural-exp.o .libs/localcharset.o .libs/threadlib.o
 .libs/lock.o .libs/relocatable.o .libs/langprefs.o .libs/localename.o
.libs/log.o .libs/printf.o .libs/setlocale.o .libs/version.o
.libs/xsize.o .libs/osdep.o .libs/intl-compat.o .libs/libintl.res.o
-Lc:/Users/Jeremy/cerbero/build-tools/lib  -O2 -Wl,--disable-a
uto-import -Wl,--export-all-symbols   -o .libs/libintl-8.dll
-Wl,--enable-auto-image-base -Xlinker --out-implib -Xlinker .libs/libin
Creating library file: .libs/libintl.dll.a
libtool: link: i686-w64-mingw32-ar cru .libs/libintl.a  bindtextdom.o
dcgettext.o dgettext.o gettext.o finddomain.o hash-string.o lo
admsgcat.o localealias.o textdomain.o l10nflist.o explodename.o
dcigettext.o dcngettext.o dngettext.o ngettext.o plural.o plural-exp
.o localcharset.o threadlib.o lock.o relocatable.o langprefs.o localename.o
log.o printf.o setlocale.o version.o xsize.o osdep.o int
l-compat.o libintl.res.o
libtool: link: i686-w64-mingw32-ranlib .libs/libintl.a
'.libs/libintl.a': No such file
make: *** [libintl.la] Error 1
***** Error running 'bootstrap' command:
Recipe 'gettext' failed at the build step 'compile'

Not sure if this is relevant, but I notice when cloning that I get a

$ git clone --branch 1.2 http://cgit.freedesktop.org/gstreamer/cerbero
Cloning into 'cerbero'...
warning: unable to unlink
Permission denied

So I seem to get inconsistent results, which suggests to me something in my
environment outside of the cerbero folder is a problem.

Any other suggestions for things to try? Thanks.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20140219/6025fd7b/attachment.html>

More information about the gstreamer-devel mailing list