gstreamer1.0, gst-omx, gstomx.conf,

jlancaster jeff_lancaster at
Tue Oct 20 09:19:08 PDT 2015

I am trying to get my gstreamer1.0 plugins to tie into the accelerated
hardware/OMXIL libraries. 

Everything builds and runs except when I use plugins that use video codecs
and other accelerated hardware components.

I am using gstomx.conf to configure the plugins in the omx libraries
(curious, I didn't need to use gstomx.conf when I run
gst-0.10/gst-openmax/ components).

When I run gst-inspect-1.0 I see the omx plugins that I expect:
omx:  omxmpeg4videodec: OpenMAX MPEG4 Video Decoder
omx:  omxmpeg4videoenc: OpenMAX MPEG4 Video Encoder
omx:  omxh264dec: OpenMAX H.264 Video Decoder
omx:  omxh264enc: OpenMAX H.264 Video Encoder
omx:  omxaacenc: OpenMAX AAC Audio Encoder
omx:  omxh263dec: OpenMAX H.263 Video Decoder
omx:  omxh263enc: OpenMAX H.263 Video Encoder
omx:  omxmjpegdec: OpenMAX MJPEG Video Decoder
omx:  omxwmvdec: OpenMAX WMV Video Decoder


When I run:
GST_DEBUG=*:3 gst-launch-1.0 -v playbin uri=file:///home/root/new.mp4

I get:
ERROR omx gstomx.c:646:gst_omx_component_new:<omxh264dec-omxh264dec0> Failed
to get component handle 'video_decoder.avc' from core
'/usr/lib/': 0x80001003

The only thing I can think of that I am doing wrong is that
'component-name=video_encoder.avc', where 'video_encoder.avc' may not be the
right string to identify the handle. Looking at the sources,
'video_encoder.avc' is the only thing I can find for that component-name. 

Any thoughts, ideas, things to try are welcome.


Jeff Lancaster
View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list