Missing element: MPEG4-GENERIC audio RTP depayloader

fbrcosta fbrcosta at gmail.com
Mon May 8 20:19:34 UTC 2017

Hi all,

I'm having a problem saving a file from a rtsp source, the pipeline i'm
using is this:
*gst-launch-1.0 rtspsrc location=rtsp:// ! decodebin
! x264enc ! mp4mux ! filesink location=file.mp4*

But everytime i run this, i keep getting the same error 
*Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
Progress: (request) SETUP stream 1
Progress: (open) Opened Stream
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Progress: (request) Sending PLAY request
Progress: (request) Sending PLAY request
Progress: (request) Sent PLAY request
Missing element: MPEG4-GENERIC audio RTP depayloader
ERROR: from element /GstPipeline:pipeline0/GstDecodeBin:decodebin0: Your
GStreamer installation is missing a plug-in.
Additional debug info:
gstdecodebin2.c(3977): gst_decode_bin_expose ():
no suitable plugins found
Execution ended after 0:00:00.021710679
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...*

I've installed all the plugins and i've searched for days what i'm missing,
but i was unable to find a solution for this. Can you help me with this?

Thanks in advance

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/Missing-element-MPEG4-GENERIC-audio-RTP-depayloader-tp4682956.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list