rtsp to hlssink with audio

Jerry Geis jerry.geis at gmail.com
Wed Dec 18 16:35:41 UTC 2019

So I tried a couple things.

1) removed the extra aacparse.
2) changed to use decodebin for the audio (the extra queue items are just
space fillers, I presume they dont matter).
3) tried to look at playbin output | grep "creating element". It basically
showed the elements I was using were correct.

gst-launch-1.0 mpegtsmux name=m ! hlssink playlist-root=/
location=hlssink.camera.1636.%05d.ts target-duration=1 max-files=3
playlist-length=2 playlist-location=playlist.camera.1636.m3u8 rtspsrc
latency=0 location=rtsp:// name=d d. ! rtph264depay ! h264parse
config-interval=-1 ! queue ! m. d. ! decodebin ! queue ! queue !
audioconvert ! audioresample ! audiorate ! avenc_aac bitrate=96000
compliance=-2 ! queue ! m.

I am not seeing why the audio is not working here. Again playbin output to
my LCD works just fine with video and audio.

Thanks for the suggestions. I could not try the other pipeline as my
computer did not have those elements.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/gstreamer-devel/attachments/20191218/6fb03f20/attachment.htm>

More information about the gstreamer-devel mailing list